Closed Bug 1276686 Opened 3 years ago Closed 3 years ago

Selection handles are displayed when tapping on the reader view toolbar

Categories

(Firefox for Android :: Reader View, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 49
Tracking Status
firefox46 --- unaffected
firefox47 --- unaffected
firefox48 + verified
firefox49 --- verified
fennec 48+ ---

People

(Reporter: alex.caziuc, Assigned: ralin)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Selection handles.png
Environment
Device: Sony Xperia Z5 (Android 5.1.1)
Build: Nightly 49.0a1 (2016-05-30)

Steps to reproduce:
1.Open wikipedia.org
2.Tap on reader view icon to enter reader mode
3.Tap on "Aa" icon
4.Tap somewhere near the "+" sign at the edge of the reader mode toolbar screen

Actual result:
The selection handles are displayed as if you are selecting text.

Expected result:
The handles shouldn't appear at all.

Regression window:
Good build:29.12.2015
Bad build:30.12.2015

Enter pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?47b49b0d32360fab04b11ff9120970979c426911=af4e3ce8c487&tochange=47b49b0d32360fab04b11ff9120970979c426911

Note:This is reproducing since Nightly 45, but not reproducing on Release and Beta. So this might be an APZ related issue.
tracking-fennec: --- → ?
Mike it looks like this might be related to native text selection, do you have time to take a look?
Assignee: nobody → michael.l.comella
tracking-fennec: ? → 48+
Flags: needinfo?(michael.l.comella)
This is HTML/CSS, so maybe this is something Ray or someone else in Taipei could help with.

I believe there is some CSS rule that you can use to prevent text selection on an element, and I thought we were using that already.
Flags: needinfo?(ralin)
The selection handles present when clicking on any margin region. 

As Margaret said, a simple line of css rule could handle it. I'm not sure whether it is the answer to this bug, but if the patch looks reasonable, we could just land it. Thanks.
Flags: needinfo?(ralin)
Comment on attachment 8759689 [details]
Bug 1276686 - Prevent selection when tapping on reader mode toolbar.

https://reviewboard.mozilla.org/r/57594/#review54384
Attachment #8759689 - Flags: review?(margaret.leibovic) → review+
Awesome, this is exactly what I was thinking of! :)
Assignee: michael.l.comella → ralin
Keywords: checkin-needed
Flags: needinfo?(michael.l.comella)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/094a647ca9c2
Prevent selection when tapping on reader mode toolbar. r=margaret
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/094a647ca9c2
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Verified using:
Device: Galaxy S6 Edge(Android 5.1.1)
Build: Firefox for Android Aurora- 49.0a2(2016-06-14)and Nightly - 50.0a1(2016-06-16)
If you want to request uplift for 48, this could still make it into beta 6.
Flags: needinfo?(ralin)
Hi Ray,
Since this patch also affects 48, do you want to uplift this for 48 if this patch is not too risky?
Track this as this is a regression in 48.
sorry for the late reply. 

I don't think this bug is too risky, it occurs only when user mis-click on the panel.
Flags: needinfo?(ralin)
Hi Ray,
Can you create a uplift request for 48?
Flags: needinfo?(ralin)
Comment on attachment 8759689 [details]
Bug 1276686 - Prevent selection when tapping on reader mode toolbar.

Approval Request Comment
[Feature/regressing bug #]: Bug 1276686
[User impact if declined]: As described
[Describe test coverage new/current, TreeHerder]: tested and landed a month ago. No related bug caused by this bug.
[Risks and why]: Low. One line css modification to avoid selection action. 
[String/UUID change made/needed]: None
Flags: needinfo?(ralin)
Attachment #8759689 - Flags: approval-mozilla-beta?
Comment on attachment 8759689 [details]
Bug 1276686 - Prevent selection when tapping on reader mode toolbar.

This patch fixes a regression. Take it in 48 beta 8.
Attachment #8759689 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This needs to be verified in 48 beta 8.
Flags: qe-verify+
Verified as fixed on latest beta, 48.0b9, on a Samsung Galaxu S6 edge(Android 6.0.1) and on a Samsung Galaxy Tab S2 with Android 5.0.1
I'm changing the status to verified fixed considering that the bug is verified on all versions.
Status: RESOLVED → VERIFIED
Clearing qe-verify+ based on the comment 19 and 20.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.