Mozilla crashes on startup if volume has bidirectionality mark

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
critical
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Shoshannah Forbes, Assigned: mkaply)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.8+) Gecko/20020224
BuildID:    2002022408

if the volume name has bidrectional marks in it, mozilla crashes on startup.
see: http://homepage.mac.com/gabidanon/cleanbidi.html for more info on those marks.
althugh there is a workaround, if a user uses both system 9 and system 10, those
marks get re-added to the volume name every time the user boots into system 9.
Very very annoying. Part of this is an apple bug- I have seen other carbon
application crash due to a very similar bug.

Reproducible: Always
Steps to Reproduce:
1. make sure your volume name has a bidirectionality character in it.
2. try to run mozilla under X
3.

Actual Results:  crash. you can find a crash log posted at:
http://groups.google.com/groups?hl=en&selm=5b0ec608.0202080722.50f9638c%40posting.google.com

Expected Results:  mozilla should run

those marks do not seem to affect mozilla on 9.x.
(Reporter)

Updated

16 years ago
Blocks: 154625
(Reporter)

Comment 1

15 years ago
still there, even after osx 10.2.1

Comment 2

13 years ago
type on summary: makr instead of mark.
(Assignee)

Updated

13 years ago
Summary: Mozilla crashes on startup if volume has bidirectinality makr → Mozilla crashes on startup if volume has bidirectionality mark
I reproduced this on versions of Mozilla up to (and including) 1.2.1, but this
WFM on 1.3.x and onwards.

Marking WFM. Shoshannah - can you please verify?
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.