[TV 2.6] When receive PIN dismiss from smart system, sends error to client actively

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: etsai, Assigned: etsai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.6 fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

Currently we only handle when one client used PIN code, the other client send PIN code receives error (PIN expire).
This bug will actively send error when PIN code dismiss from smart system, no matter it's manually or timeout.
Assignee: nobody → etsai
blocking-b2g: --- → 2.6?
Depends on: 1207996
Whiteboard: [ft:conndevices]
Created attachment 8758179 [details] [review]
Patch 1. Handle PIN dismiss from system app
Attachment #8758179 - Flags: review?(schien)
(In reply to Eric Tsai from comment #0)
> Currently we only handle when one client used PIN code, the other client
> send PIN code receives error (PIN expire).
> This bug will actively send error when PIN code dismiss from smart system,
> no matter it's manually or timeout.

Will the client that receives PIN-expired error trigger re-connect automatically?
Flags: needinfo?(etsai)
Yes, when receives PIN-expired error, client shows the error message on paring page. Then start reconnection to pairing page again.
chunmin: please correct me if client side's implementation detail is wrong.
Flags: needinfo?(etsai) → needinfo?(cchang)
Comment on attachment 8758179 [details] [review]
Patch 1. Handle PIN dismiss from system app

Thanks for the explanation, lgtm.
Attachment #8758179 - Flags: review?(schien) → review+
Comment on attachment 8758179 [details] [review]
Patch 1. Handle PIN dismiss from system app

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 1276855
User impact if declined: malfunction in some use case
Testing completed: self-tested
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: N/A
Flags: needinfo?(cchang)
Attachment #8758179 - Flags: approval-mozilla-b2g48?
Status: NEW → ASSIGNED

Comment 6

2 years ago
Comment on attachment 8758179 [details] [review]
Patch 1. Handle PIN dismiss from system app

Approve for TV 2.6
Attachment #8758179 - Flags: approval-mozilla-b2g48? → approval-mozilla-b2g48+

Updated

2 years ago
blocking-b2g: 2.6? → 2.6+
Flags: needinfo?(xeonchen)
https://github.com/mozilla-b2g/gecko-b2g/commit/f0434fd31da962cf5198e159e3b186879359b328
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-b2g-v2.6: --- → fixed
Flags: needinfo?(xeonchen)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.