Save button does not come up when opening file from Windows Explorer

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE QAHP)

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

16 years ago
using 2/25 build of windows

1) create an HTML file on your desktop
2) launch Windows Explorer
3) right click on that HTML file and choose "Edit"

the file gets loaded into a composer window, but there is no
Save button on toolbar! You are forced to use "Save As".

Comment 1

16 years ago
I am seeing this problem on Win 2k using the 02-25 trunk build as well.
(Assignee)

Comment 2

16 years ago
Created attachment 71332 [details] [diff] [review]
Fix

Side effect of recent publish UI changes.
This calls method that sets save/publish UI
during editor's onload command.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1+, patch, review
Whiteboard: FIX IN HAND, needr=,sr=
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
Is plain text editor also broken?  Do we need to address that case?
(Assignee)

Comment 4

16 years ago
*** Bug 127738 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
Comment on attachment 71332 [details] [diff] [review]
Fix

should have shown more context. This is in
function EditorOnLoad()
(Assignee)

Comment 6

16 years ago
Created attachment 71550 [details] [diff] [review]
Update: Need to put same call in TextEditorOnLoad()
Attachment #71332 - Attachment is obsolete: true

Comment 7

16 years ago
Comment on attachment 71550 [details] [diff] [review]
Update: Need to put same call in TextEditorOnLoad()

url is not defined in TextEditorOnLoad
Attachment #71550 - Flags: needs-work+
(Assignee)

Comment 8

16 years ago
Created attachment 71558 [details] [diff] [review]
Update.

Of course it helps to get it right.
Attachment #71550 - Attachment is obsolete: true

Comment 9

16 years ago
Comment on attachment 71558 [details] [diff] [review]
Update.

r=brade
Attachment #71558 - Flags: review+
(Assignee)

Comment 10

16 years ago
Comment on attachment 71558 [details] [diff] [review]
Update.

sr=sfraser
Attachment #71558 - Flags: superreview+
(Reporter)

Comment 11

16 years ago
lets get this fix in...
(Assignee)

Comment 12

16 years ago
I'll try or 0.9.9
Target Milestone: mozilla1.0 → mozilla0.9.9

Comment 13

16 years ago
Comment on attachment 71558 [details] [diff] [review]
Update.

a=asa (on behalf of drivers) for checkin to 0.9.9 and the trunk
Attachment #71558 - Flags: approval+
(Assignee)

Updated

16 years ago
Whiteboard: FIX IN HAND, needr=,sr= → FIX IN HAND reviewed
(Assignee)

Comment 14

16 years ago
checked into both trunk and 0.9.9 branch

Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND reviewed

Comment 15

16 years ago
I am still seeing this problem on today's trunk build (03-04) on Win XP.

I am reopening this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 16

16 years ago
Do you see the Publish button instead?
(Assignee)

Comment 17

16 years ago
Also, what is the URL of the file: from the window caption and from Format |
Page Title and Properties dialog).

Comment 18

16 years ago
Yes, I see a publish button instead.

The title bar lists the file as:  asdf (file:/.../asdf.html) - Composer
Format - Page Title and Properties lists the file as:  file:///C:/Documents%
20and%20Settings/QA%20Tester/Desktop/asdf.html
(Reporter)

Updated

16 years ago
Whiteboard: EDITORBASE QAHP
(Assignee)

Comment 19

16 years ago
Created attachment 72652 [details] [diff] [review]
New fix

So the problem is the "file" scheme isn't being detected because initial URL is

a local Windows filepath, which is totally legal. The new fix does this:
1. Removes calls to SetSaveAndPublishUI() from the editor's onload handlers and

from EditorStartup code. It's too early to call then.
2. Call SetSaveAndPublishUI() in the NotifyDocumentCreated callback; at this
time, we can get the document URL, which will be converted to "file://..." 
format.
3. Change editorOverlay.xul to initially hide the Publish button so the Save
button displays during document loading. When finished, SetSaveAndPublishUI
switches to the Publish button (when appropriate) without jiggling the toolbar.
Attachment #71558 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Status: REOPENED → ASSIGNED
Whiteboard: EDITORBASE QAHP → EDITORBASE QAHP, FIX IN HAND, need r=,sr=
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 20

16 years ago
Comment on attachment 72652 [details] [diff] [review]
New fix

r=brade
Attachment #72652 - Flags: review+
(Assignee)

Updated

16 years ago
Whiteboard: EDITORBASE QAHP, FIX IN HAND, need r=,sr= → EDITORBASE QAHP, FIX IN HAND, need sr=

Comment 21

16 years ago
Comment on attachment 72652 [details] [diff] [review]
New fix

sr=kin@netscape.com
Attachment #72652 - Flags: superreview+

Updated

16 years ago
Whiteboard: EDITORBASE QAHP, FIX IN HAND, need sr= → EDITORBASE QAHP, FIX IN HAND, reviewed

Comment 22

16 years ago
Comment on attachment 72652 [details] [diff] [review]
New fix

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #72652 - Flags: approval+
(Assignee)

Comment 23

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Whiteboard: EDITORBASE QAHP, FIX IN HAND, reviewed → EDITORBASE QAHP

Comment 24

16 years ago
Verified on Win XP using build 03-07.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.