If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

static background/border bleed over top of float background and border

VERIFIED FIXED in M6

Status

()

Core
Layout
P2
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: buster)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

see http://www.w3.org/TR/REC-CSS2/visuren.html#floats - it explains the correct
behavior in detail.  A block element should be behind a float (this is the bug
here), but an inline one, if positioned (and this needs to be done actively) so
that it is over top of the float, should be above it.

Updated

19 years ago
Status: NEW → ASSIGNED
This problem also occurs with the non floating H2's on my homepage,
http://www.fas.harvard.edu/~dbaron/ .  The page may be changed, though.
This was fixed by your checkin two (?) days ago.
Actually, it was only fixed in some cases.  I am changing the URL from
http://www.webstandards.org/ie/box_vert.html (where it is now fixed) to
http://www.w3.org/Style/CSS/Test/current/sec5525c.htm because the problem still
occurs when the float started before the box level element.  Then the inline
elements are on top, correctly, but the backgrounds do not stack correctly.
See the sixth test case in the above URL.
Priority: P2 → P1
Summary: padding and border bleed over top of floats → padding and border bleed over top of floats ; crashes viewer
Viewer (99-01-27) now crashes on the above URL.  Raising priority to P1 and
changing title.  Display issues need to be fixed after crash is fixed.
If this helps, I get the following GPF:

VIEWER caused an invalid page fault in
module RAPTORHTML.DLL at 014f:005c030f.
Registers:
EAX=00000001 CS=014f EIP=005c030f EFLGS=00010297
EBX=f74e232f SS=0157 ESP=0091b0b4 EBP=0091b0e4
ECX=0091b0cc DS=0157 ESI=0091b8b0 FS=1917
EDX=40000000 ES=0157 EDI=0091ba50 GS=0000
Bytes at CS:EIP:
8b 03 53 ff 50 38 8b 45 e8 80 78 02 01 75 07 8b
Stack dump:
00000007 0091b0cc 0091b8c8 0091b8b0 80000000 00000001 00000020 7800acf3
00000000 00000000 00000948 00000000 0091b11c 005c0154 00aa1360 0091b784

Comment 6

19 years ago
Setting all current Open/Normal to M4.

Updated

19 years ago
Priority: P1 → P2

Comment 7

19 years ago
I fixed the crash; however the page still evidences some layout problems so I'm
leaving the bug open until I dig into it furthur.
Summary: padding and border bleed over top of floats ; crashes viewer → static background/border bleed over top of float background and border
Modified title from "padding and border bleed over top of floats ; crashes
viewer" to "static background/border bleed over top of float background and
border"

Also, another example of this problem is http://css.nu/exp/layer-ex3b.html .
This seems related to 1413.

Comment 10

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
Severity: normal → critical

Comment 11

19 years ago
*** Bug 3496 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 12

19 years ago
Fixed. I updated the painting order so that floats paint properly

Updated

19 years ago
QA Contact: 4144 → 4110
Status: RESOLVED → VERIFIED
Verified fixed.
You need to log in before you can comment on or make changes to this bug.