Vertical scrollbar thumb disappears on a very long pages

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Ilia, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
To reproduce the bug:
1. Load the URL
2. Wait until the page will be downloaded completely.

Results:
The thumb is shrinking as more of the page is loaded and eventually disappears
(shrinks to zero length)

Expected results:
The thumb is shrinking to some minimum length and when doesn't shrink any more.

Comments
It seems that the thumb length is calculated as a proportion of the
total_page_height/window_height. 
For very long pages it caused the thumb to be so short that is disappears.
(Assignee)

Comment 1

16 years ago
The requested URL /local-access-only/l10n/www/localization/English_Russian was
not found on this server.
(Reporter)

Comment 2

16 years ago
To jag:

Ooops..
It seems that Bugzilla mangled the URL.
The correct URL is:
http://l10n.openoffice.org./localization/English_Russian_OOo_Glossary.htm

Tested it again from a new window - the bug reproduced OK.

I feel that any page long enough will suffice - the mentioned is just the one
I'd  hapeened to hit into.

Comment 3

16 years ago
CONFIRMing on build 2002022503, Win98, although it takes a *long* time to load
the test page, and Mozilla seems like it's locked until everything finishes
loading.  For what it's worth, I really feel the scrollbar thumb should never
get smaller than about the height of the scrollbar arrows.  Anything smaller is
too tough to grab for most people.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
Not just long pages. Also on pages, apparently, where the images are longer than
the text:
http://www.newsforge.com/article.pl?sid=02/03/15/1319229

Both URLs cause problems with v0.99: Build ID: 2002031106
on Mac OS 9. Note that Mac OS scrollbar thumbs are fixed in size.

Comment 5

16 years ago
This bug is also reproducible on OS X, build 2002031005. Should be All/All.
(Reporter)

Comment 6

16 years ago
Works for me with the Mozilla build 2002051006 (RC2) on WinNT4 SP6
(NT 4.00.1381)

Thanks !!!

Can anyone confirm this on another platforms, so the bug can be marked as "FIXED" ?

Comment 7

16 years ago
Yes, it also works for me with 2002051006 (RC2) on Win2k.

Comment 8

16 years ago
Also WFM with RC3 (2002052309) on Linux.So Ilia, if you like to close this bug...
(Reporter)

Comment 9

16 years ago
Looks as the bug is solved (On Win32 & Linux platforms that's confirmed).
Close it. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.