Closed Bug 1277123 Opened 3 years ago Closed 3 years ago

Can't interact with scroll bar on certain page

Categories

(Core :: Layout, defect)

48 Branch
Unspecified
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla50
Tracking Status
firefox47 --- unaffected
firefox48 blocking verified
firefox49 + verified
firefox50 + verified

People

(Reporter: AdamBugzilla, Assigned: tnikkel)

References

Details

(Keywords: platform-parity, regression)

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160531004027

Steps to reproduce:

Url: http://www.intel.com/content/www/us/en/support/graphics-drivers/000005526.html

Hovering over the scrollbar doesn't highlight the scrollbar and clicking and dragging results in selecting elements on the page.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cc9051869d1a9078a821da5d1639299f9e836e0e&tochange=1ee604ae873ffae665e745b3553fb1c406dbdd6a

Regressed by: 1ee604ae873f	Matt Woodrow — Bug 1265237 - Clear clipping for out-of-flow frames that we are descending into but haven't stored explicit clip data for. r=mstange
Blocks: 1265237
Flags: needinfo?(rkothari)
Flags: needinfo?(mstange)
Flags: needinfo?(matt.woodrow)
Let's track this scrollbar regression for 48 and 49. 
There is already a ni for Matt so I will wait for him to provide additional information.
This is a pretty core and commonly used functionality. Tagging this as a blocker for Fx48.
Flags: needinfo?(rkothari)
This is not reproducible on OS X for me, neither with overlay scrollbars nor with classic scrollbars.
Yeah, it seems to be Windows only (maybe Linux too, I haven't tried). I even tried removing "position: relative" and "z-index: maxint" from the scrollbars on mac (and using classic scrollbars) and that had no change.

I don't have a reduced testcase yet, but there is a form inside a position: fixed element, with the position: fixed element having zero size that is causing the problem on the page. I'm continuing to work on it.
Attached file a reduced html
Reproduced on Ubuntu14.04 and Windows10
Keywords: pp
OS: Unspecified → All
Thank you for the reduced testcase!
Assignee: nobody → tnikkel
Flags: needinfo?(mstange)
Flags: needinfo?(matt.woodrow)
Tracking 50+ for this scrollbar egression.
Timothy, do you have an eta for this bug? Thanks
Flags: needinfo?(tnikkel)
On PTO, don't have a computer that can reproduce the bug with me.
Flags: needinfo?(tnikkel)
Markus, do you know who could manage this? This is a blocking issue for 48.
Flags: needinfo?(mstange)
Timothy should be back already.
Flags: needinfo?(mstange)
Attached patch patch (obsolete) — Splinter Review
Botond, can you try this patch again on your machine without any other patches applied? I think it should be correct. Just want to verify that it wasn't this patch that was causing the weird issues on your machine.
Attachment #8767817 - Flags: review?(matt.woodrow)
Attachment #8767817 - Flags: feedback?
Attached patch patchSplinter Review
And compiles now.
Attachment #8767817 - Attachment is obsolete: true
Attachment #8767817 - Flags: review?(matt.woodrow)
Attachment #8767817 - Flags: feedback?
Attachment #8767843 - Flags: review?(matt.woodrow)
Attachment #8767843 - Flags: feedback?
Attachment #8767843 - Flags: feedback? → feedback?(botond)
Duplicate of this bug: 1283829
Attachment #8767843 - Flags: review?(matt.woodrow) → review+
Comment on attachment 8767843 [details] [diff] [review]
patch

I can confirm that this patch fixes the reduced testcase for me on Linux. (I can't reproduce the problem on the original page.)
Attachment #8767843 - Flags: feedback?(botond) → feedback+
Sounds promising! If you land it please request uplift. I have it marked as a blocker for 48 release. So we will also likely test this once we land a fix on 48 and 49.
Flags: needinfo?(tnikkel)
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6de59178cfa0
Only clear the containing block clip when entering an out of flow with an unknown clip. r=mattwoodrow
https://hg.mozilla.org/mozilla-central/rev/6de59178cfa0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
This missed the beta 7 build but could still make it into beta 8 later this week.
Comment on attachment 8767843 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1265237
[User impact if declined]: scrollbars on some pages might not work, not a huge percentage of sites, but it clearly comes up
[Describe test coverage new/current, TreeHerder]: none yet, working on a test
[Risks and why]: not risky
[String/UUID change made/needed]: none
Attachment #8767843 - Flags: approval-mozilla-beta?
Attachment #8767843 - Flags: approval-mozilla-aurora?
Comment on attachment 8767843 [details] [diff] [review]
patch

Review of attachment 8767843 [details] [diff] [review]:
-----------------------------------------------------------------

This patch fixes a regression. Take it in 48 beta 8 and aurora.
Attachment #8767843 - Flags: approval-mozilla-beta?
Attachment #8767843 - Flags: approval-mozilla-beta+
Attachment #8767843 - Flags: approval-mozilla-aurora?
Attachment #8767843 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Verified as fixed using Firefox 48 beta 9, latest Aurora 49.0a2 and latest Nightly 50.0a1 2016-07-19 under Win 10 64-bit and Ubuntu 14.04 64-bit.
Flags: needinfo?(tnikkel)
You need to log in before you can comment on or make changes to this bug.