Creating message from template is broken (UTF-8 not used)

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Yukinoroh, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

I selected a template to write a new message.


Actual results:

Japanese text is question marks in black diamonds. It means that the software doesn't know how to process the encoding. But I've been using these templates for a long time and didn't edit them!

Creating a new template, making sure it is encoded as UTF-8 and saving it produces the same result. I guess UTF-8 is just not used when creating a message from a tempklate.


Expected results:

Well, I should be able to use the template.
(Reporter)

Updated

2 years ago
Severity: normal → major
(Reporter)

Updated

2 years ago
Summary: Editing templates is broken (UTF-8 not used) → Creating message from template is broken (UTF-8 not used)
(Reporter)

Comment 1

2 years ago
Creating a new message from a message I have sent before is also broken the same way.
(Reporter)

Comment 2

2 years ago
Creating a new message from a message I have just sent is also broken.
You reported the bug against TB 38. There is no support for this version any more.

I've tried saving a template with Japanese text (これは長い日本語のテキストですので、行が折れると思います。) as UTF-8 template and editing the template as new message works perfectly in TB 45.1.1.

So I cannot reproduce your problem.

BTW: Editing a message as new, either template or other sent message, behaves the same, as you noticed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.