Closed Bug 1277163 Opened 8 years ago Closed 8 years ago

rename parameter to nsStyleContext::CalcStyleDifference and nsStyle*::CalcDifference to indicate it is the new context/struct

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: dbaron, Assigned: heycam)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We should rename the parameter to nsStyleContext::CalcStyleDifference and nsStyle*::CalcDifference (in nsStyleStruct.cpp) to indicate that the parameter must be the new context/struct and the |this| must be the old one.  (I think it's that way round, but we should definitely double-check first.)
Comment on attachment 8763140 [details]
Bug 1277163 - Rename nsStyleContext* argument to Calc(Style)Difference methods to indicate it's the new style.

https://reviewboard.mozilla.org/r/59468/#review56666

::: layout/style/nsStyleStruct.cpp:483
(Diff revision 1)
>    // color-related flags.  Given that we've already done an mComputedBorder
>    // comparison, border-style differences can only lead to a repaint hint.  So
>    // it's OK to just compare the values directly -- if either the actual
>    // style or the color flags differ we want to repaint.
>    NS_FOR_CSS_SIDES(ix) {
> -    if (mBorderStyle[ix] != aOther.mBorderStyle[ix] || 
> +    if (mBorderStyle[ix] != aNewData.mBorderStyle[ix] || 

fix this trailing space while you're here?

::: layout/style/nsStyleStruct.cpp:3428
(Diff revision 1)
>    // change this code to not reconstruct frames on changes to the
>    // 'content' property, then we will need to revisit the optimization
>    // in ReResolveStyleContext.
>  
> -  if (mContentCount != aOther.mContentCount ||
> -      mIncrementCount != aOther.mIncrementCount || 
> +  if (mContentCount != aNewData.mContentCount ||
> +      mIncrementCount != aNewData.mIncrementCount || 

same here (trailing space), and 2 more times in this function)
Attachment #8763140 - Flags: review?(dbaron) → review+
Assignee: nobody → cam
Status: NEW → ASSIGNED
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/26d903c059b7
Rename nsStyleContext* argument to Calc(Style)Difference methods to indicate it's the new style. r=dbaron
https://hg.mozilla.org/mozilla-central/rev/26d903c059b7
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: