DOM: Fix constants missing for splice

RESOLVED FIXED in Firefox 49

Status

()

Core
DOM
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: hev, Assigned: hev)

Tracking

unspecified
mozilla49
All
Linux
Points:
---

Firefox Tracking Flags

(firefox49 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: Argument 5 of splice is undefined
Full stack: ffi@resource://gre/modules/osfile/osfile_shared_allthreads.jsm:1109:17
pump_splice@resource://gre/modules/osfile/osfile_unix_front.jsm:603:18
copy@resource://gre/modules/osfile/osfile_unix_front.jsm:658:23
Agent.write@resource:///modules/sessionstore/SessionWorker.js:215:9
worker.dispatch@resource:///modules/sessionstore/SessionWorker.js:21:24
anonymous/AbstractWorker.prototype.handleMessage@resource://gre/modules/workers/PromiseWorker.js:122:16
@resource:///modules/sessionstore/SessionWorker.js:30:41
EventListener.handleEvent*@resource:///modules/sessionstore/SessionWorker.js:30:1

*************************
console.error: 
  Could not write session state file 
  Message: TypeError: Argument 5 of splice is undefined
  Stack:
    ffi@resource://gre/modules/osfile/osfile_shared_allthreads.jsm:1109:17
pump_splice@resource://gre/modules/osfile/osfile_unix_front.jsm:603:18
copy@resource://gre/modules/osfile/osfile_unix_front.jsm:658:23
Agent.write@resource:///modules/sessionstore/SessionWorker.js:215:9
worker.dispatch@resource:///modules/sessionstore/SessionWorker.js:21:24
anonymous/AbstractWorker.prototype.handleMessage@resource://gre/modules/workers/PromiseWorker.js:122:16
@resource:///modules/sessionstore/SessionWorker.js:30:41
EventListener.handleEvent*@resource:///modules/sessionstore/SessionWorker.js:30:1

  ffi@resource://gre/modules/osfile/osfile_shared_allthreads.jsm:1109:17
pump_splice@resource://gre/modules/osfile/osfile_unix_front.jsm:603:18
copy@resource://gre/modules/osfile/osfile_unix_front.jsm:658:23
Agent.write@resource:///modules/sessionstore/SessionWorker.js:215:9
worker.dispatch@resource:///modules/sessionstore/SessionWorker.js:21:24
anonymous/AbstractWorker.prototype.handleMessage@resource://gre/modules/workers/PromiseWorker.js:122:16
@resource:///modules/sessionstore/SessionWorker.js:30:41
EventListener.handleEvent*@resource:///modules/sessionstore/SessionWorker.js:30:1

Looks pump_splice access a undefined constant variable SPLICE_F_MORE:
https://dxr.mozilla.org/mozilla-central/rev/4d63dde701b47b8661ab7990f197b6b60e543839/toolkit/components/osfile/modules/osfile_unix_front.jsm#605
(Assignee)

Comment 1

2 years ago
Created attachment 8758987 [details] [diff] [review]
0001-DOM-Fix-constants-missing-for-splice.patch

$ cat /tmp/t.js
var Cu = Components.utils;
var SharedAll = Cu.import("resource://gre/modules/osfile/osfile_shared_allthreads.jsm");
var Const = SharedAll.Constants.libc;
print(Const.SPLICE_F_MORE);

$ ./run-mozilla.sh ./xpcshell -g ../firefox -f /tmp/t.js 
undefined

Patched:
$ ./run-mozilla.sh ./xpcshell -g ../firefox -f /tmp/t.js 
4
Attachment #8758987 - Flags: review?(dteller)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1277434
Comment on attachment 8758987 [details] [diff] [review]
0001-DOM-Fix-constants-missing-for-splice.patch

Review of attachment 8758987 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #8758987 - Flags: review?(dteller) → review+

Comment 4

2 years ago
Pushed by r@hev.cc:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cd31d578be58
DOM: Fix constants missing for splice. r=Yoric
backed out for bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=29280721&repo=mozilla-inbound
Flags: needinfo?(r)

Comment 6

2 years ago
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4a84c4e71f09
Backed out changeset cd31d578be58 for bustage on a CLOSED TREE

Comment 9

2 years ago
Pushed by r@hev.cc:
https://hg.mozilla.org/integration/mozilla-inbound/rev/212dd0c9cdbb
DOM: Fix consts missing for splice. r=Yoric

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/212dd0c9cdbb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.