Closed Bug 1277454 Opened 5 years ago Closed 5 years ago

SeaMonkey Help developer_tools.xhtml: fix for Bug 1275660 "Dead web hyperlink for DOM Inspector tutorial" needs to be ported

Categories

(Mozilla Localizations :: nl / Dutch, defect)

Unspecified
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: RainerBielefeldNG, Unassigned)

References

(Blocks 1 open bug)

Details

The problem of "Bug 1275660 developer_tools.xhtml: Dead web hyperlink for DOM Inspector tutorial" is reproducible with seamonkey-2.40.nl.langpack.xpi. 

Fix needs to be ported to translation.

I will report a separate Bug for other obsolete stuff in that help page.

@L10n-Experts:
Will we need separate Bug Reports for each SeaMonkey Localization or is there some automatism?
Hello Rainer,

Thanks for filing this. Also in reply to your question, I have some thoughts though:

- SM Help for Dutch isn’t localized and probably never will be, which means it’s a copy of en-US. As a result, any en-US change will be fixed by itself at the next l10n update.
- Current en-US change is applied to trunk only, so that means bugs like these can’t be fixed yet (by syncing) until this has landed on aurora and updates are merged to trunk afterwards, since most locales work on aurora only.
-  Locales involved (the ones that do localize Help) should notice the en-US change in aurora as well, and there is no point fixing aurora based on trunk changes beforehand.
- And of course, seamonkey-2.40.nl.langpack.xpi would not include the fix. Some locales may also have trouble (and therefore temporarily stopped) updating their aurora localizations since nightly builds are broken (bug 1222878), so bugs like these may linger until they are available again.

In short: even though I understand the wish to have a master bug for SM Help fixes, aren’t you creating unnecessary bugs and workload?
(In reply to Ton from comment #1)
> As a result, any en-US change will be fixed by itself at the next l10n update

That seems to work, at least I don't see any longer the outdated Venkman stuff in seamonkey-2.46a1.nl.langpack.xpi, what still was in seamonkey-2.40.nl.langpack.xpi.
And indeed, some months ago I observed that the French Help did not update for no versions (I can't remember whether it was aurora or something else).

So I think for now we will ignore all SM localizations with untranslated (ne-US) Help. So this one is INVALID, no need for a separat fix.

For SM localizations with localized help we will see. May be we will push all not text language related corrections (Linkfix, deletion of outdated contents, ...) to the code and then we will try to find a way to ask the localization teams to do the text language related fixes (changes in wording).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
See Also: → 1247386
You need to log in before you can comment on or make changes to this bug.