Open Bug 1277483 Opened 4 years ago Updated 2 years ago

Move --enable-strip and --enable-install-strip to moz.configure

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

People

(Reporter: Ms2ger, Unassigned)

Details

Attachments

(2 files)

No description provided.
Comment on attachment 8759092 [details] [diff] [review]
Move --enable-strip and --enable-install-strip to moz.configure

Review of attachment 8759092 [details] [diff] [review]:
-----------------------------------------------------------------

::: moz.configure
@@ +228,5 @@
>  
>  set_config('MOZ_SYSTEM_HUNSPELL', system_hunspell)
>  
> +
> +option('--enable-strip',

These would be better in build/moz.configure/toolchain.configure.
Attachment #8759092 - Flags: review?(mh+mozilla) → review+
sorry had to back this out for problems like https://treeherder.mozilla.org/logviewer.html#?job_id=29408508&repo=mozilla-inbound
Flags: needinfo?(Ms2ger)
Any idea?
Flags: needinfo?(Ms2ger) → needinfo?(mh+mozilla)
Attached file logcat
Autophone showed failures which resolved themselves when this was backed out. 

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&exclusion_profile=false&filter-searchStr=autophone&filter-tier=1&filter-tier=2&filter-tier=3&fromchange=94bf6a16d707a3450ad3360a9d02ddf65ab445aa&tochange=1330c510901a9c6b574532af366f0e9acb8beb8c

PROCESS-CRASH | autophone-s1s2 | java.lang.Exception: Error loading gecko libraries at org.mozilla.gecko.mozglue.GeckoLoader.loadGeckoLibsNative(Native Method)
Pushed by Ms2ger@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dc8e4c1174b2
Move --enable-strip and --enable-install-strip to moz.configure; r=glandium
Ah, the problem is that the implicit default was --enable-install-strip, and the patch changed that. Turn the option() into --disable-install-strip, and that should work.
Flags: needinfo?(mh+mozilla)
Pushed by Ms2ger@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3446f35deed
Move --enable-strip and --enable-install-strip to moz.configure; r=glandium
sorry had to back this out for build bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=29659211&repo=mozilla-inbound
Flags: needinfo?(Ms2ger)
So something else I failed to notice is that PKG_SKIP_STRIP has a default of 1 on msvc and when --disable-compile-environment is passed.
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/15fb9fb5775c
Backed out changeset 6134b92d1b08 
https://hg.mozilla.org/integration/mozilla-inbound/rev/d818934b7aca
Backed out changeset 34de8590421f 
https://hg.mozilla.org/integration/mozilla-inbound/rev/7eda97fe3aa7
Backed out changeset f3446f35deed for  Windows 8 x64 opt Build bustage on a CLOSED TREE
Assignee: Ms2ger → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(Ms2ger)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.