add flake8 linter support to talos

RESOLVED FIXED in Firefox 50

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jmaher, Assigned: malayaleecoder)

Tracking

unspecified
mozilla50
Points:
---

Firefox Tracking Flags

(firefox50 fixed)

Details

Attachments

(1 attachment)

Right now we run flake8 on every single talos job from the mozharness wrapper script:
https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/mozharness/mozilla/testing/talos.py#355

now there is a new kid in town with cool linting options:
https://groups.google.com/forum/#!msg/mozilla.tools/iMzB0QrarXA/_hDdPWDfAwAJ

We should remove the flake8 references from talos.py and use the new flake8 work in the new linting job.
malayaleecoder, this seems like a great next bug for you to work on!
Flags: needinfo?(malayaleecoder)
Cool, I will take a look at this :)
Assignee: nobody → malayaleecoder
Status: NEW → ASSIGNED
Flags: needinfo?(malayaleecoder)
Duplicate of this bug: 1278257
Attachment #8765788 - Flags: review?(jmaher)
Comment on attachment 8765788 [details] [diff] [review]
Bug1277490_v1.diff

Review of attachment 8765788 [details] [diff] [review]:
-----------------------------------------------------------------

thank you for the great work here!
Attachment #8765788 - Flags: review?(jmaher) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c647af2120d5
add flake8 linter support to talos r=jmaher
https://hg.mozilla.org/mozilla-central/rev/c647af2120d5
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.