Tabs switch in Ctrl+Tab preview doesn't use the same tab order when browser.ctrlTab.previews is enabled

RESOLVED DUPLICATE of bug 643118

Status

()

RESOLVED DUPLICATE of bug 643118
2 years ago
2 years ago

People

(Reporter: jkt, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

When I open 3 tabs with browser.ctrlTab.previews enabled the order in which Ctrl + Tab changes tabs doesn't behave the same as with the preference off.

Pressing Ctrl + Tab switches tab from 1 to 2, then doing the action 2 to 1 rather than 2 to 3. This creates a infinite cycle of switching between these tabs unless the user holds Ctrl and hits Tab again.

However it makes sense that it should behave in exactly the same way as normal tab ordering does, such that I can hold tab down and it switches to the next tab in the list.

This behaviour appears to be the same on Ubuntu and OSX

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 643118
Ah I misread the comment on that issue before filing.

Is there any chance we can change the functionality then with another pref it seems useful to keep the same ordering personally and could be enabled by default even as the functionality wouldn't break users flow.

I should file another bug as on ubuntu the selected tab is barely even visible when hitting tab, it's a slight glow rather than Mac where it looks like the mouseover. This certainly hindered my understanding of it.
Flags: needinfo?(dao+bmo)
(In reply to Jonathan Kingston [:jkt] from comment #2)
> Ah I misread the comment on that issue before filing.
> 
> Is there any chance we can change the functionality then with another pref
> it seems useful to keep the same ordering personally and could be enabled by
> default even as the functionality wouldn't break users flow.

I doubt it. The current behavior is the result of many iterations where we tried out different approaches.

> I should file another bug as on ubuntu the selected tab is barely even
> visible when hitting tab, it's a slight glow rather than Mac where it looks
> like the mouseover. This certainly hindered my understanding of it.

Yeah, please file a new bug.
Flags: needinfo?(dao+bmo)
(In reply to Dão Gottwald [:dao] from comment #3)
> > I should file another bug as on ubuntu the selected tab is barely even
> > visible when hitting tab, it's a slight glow rather than Mac where it looks
> > like the mouseover. This certainly hindered my understanding of it.
> 
> Yeah, please file a new bug.

I filed bug 1290094.
You need to log in before you can comment on or make changes to this bug.