Custom field "Crash Signature" link is deprecated

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: adrian, Assigned: dylan)

Tracking

Production

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Hello,

In our bugzilla there is a custom field called "Crash Signature" that allows users to put a crash signature, and turns that into a link to crash-stats.mozilla.com. However, we are currently deprecating the page where that field leads. 

Could it be possible to change that link to point to the new page we support, which is: https://crash-stats.mozilla.com/signature/?signature=%FIELD_VALUE%

For example, bug 1270916 has a Crash Signature field that leads to: 

https://crash-stats.mozilla.com/report/list?signature=IPCError-browser%20%7C%20(msgtype%3D0x2C0004%2Cname%3DPBrowser%3A%3AMsg_PDocAccessibleConstructor)%20Processing%20error%3A%20message%20was%20deseri

Instead if should lead to: 

https://crash-stats.mozilla.com/signature/?signature=IPCError-browser+%7C+%28msgtype%3D0x2C0004%2Cname%3DPBrowser%3A%3AMsg_PDocAccessibleConstructor%29+Processing+error%3A+message+was+deseri

Thanks,
Adrian
(Assignee)

Comment 1

2 years ago
Yep.
Assignee: nobody → dylan
(Assignee)

Comment 2

2 years ago
Created attachment 8759316 [details] [diff] [review]
1277600_1.patch
Attachment #8759316 - Flags: review?(dkl)
Comment on attachment 8759316 [details] [diff] [review]
1277600_1.patch

Review of attachment 8759316 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #8759316 - Flags: review?(dkl) → review+
(Assignee)

Comment 4

2 years ago
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   13161f4..5af5f0a  master -> master
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1281178
You need to log in before you can comment on or make changes to this bug.