display source map variable names in Developer Tools

RESOLVED DUPLICATE of bug 856875

Status

P5
normal
RESOLVED DUPLICATE of bug 856875
2 years ago
3 months ago

People

(Reporter: burashka-lcme, Unassigned)

Tracking

46 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.26 KB, application/zip
Details
(Reporter)

Description

2 years ago
Created attachment 8759542 [details]
forFF.zip

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 2016042500

Steps to reproduce:

1) Open HTML-file with minified JavaScript.
2) Debug minified JavaScript.



Actual results:

Minified variable names are shown (ex: `a`, `c`, `e`, etc) instead of original source names.


Expected results:

Shown original source names.

Updated

2 years ago
Component: Untriaged → Developer Tools: Debugger
James, didn't we already have a bug for this?

If not, this seems like it would be of some importance, so tentatively marking as P2.
Flags: needinfo?(jlong)
Priority: -- → P2
(In reply to Eddy Bruel [:ejpbruel] from comment #1)
> James, didn't we already have a bug for this?
> 
> If not, this seems like it would be of some importance, so tentatively
> marking as P2.

Source maps don't even have this feature, I don't think. You must be thinking of a different bug. Sourcemaps do not encode and scoping information or names of original variables, so I think this bug is invalid.
Flags: needinfo?(jlong)
Confirmed with fitzgen that the sourcemaps specification is not capable of this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

2 years ago
It's not impossible. Chrome DevTools implemented it: https://bugs.chromium.org/p/chromium/issues/detail?id=327092. In experimental functionality, but stability works.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
It's hard to tell what they are doing, but it looks like they are manually trying to re-sourcemap variable names by finding the definition location and sourcemapping that expression? We would rather improve the sourcemap spec. This isn't something we're going to do now.

Updated

a year ago
Priority: P2 → P5

Comment 6

a year ago
I discovered that this is a dup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 856875

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.