Closed Bug 1277844 Opened 3 years ago Closed 3 years ago

TB45.1.1 Advanced search pane shows "correspondents" column

Categories

(Thunderbird :: Search, defect)

45 Branch
x86_64
Windows 7
defect
Not set

Tracking

(thunderbird46 wontfix, thunderbird47 wontfix, thunderbird48 fixed, thunderbird49 fixed, thunderbird_esr4548+ fixed)

RESOLVED FIXED
Thunderbird 49.0
Tracking Status
thunderbird46 --- wontfix
thunderbird47 --- wontfix
thunderbird48 --- fixed
thunderbird49 --- fixed
thunderbird_esr45 48+ fixed

People

(Reporter: nancy.lobaugh, Assigned: jorgk)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

TB45.1.1. mail.threadpane.use_correspondents is set to false.




Actual results:

The Advanced Search (Ctrl-Shift-F) results pane shows "correspondents" instead of "from", the old default...  so I have to deselect and reselect columns manually for each search..

Have also tried with add-ons disabled, with the same behaviour.




Expected results:

I expected that by setting the mail.threadpane.use_correspondents to false, this preference would carry over to searches as well. Can't find anything obvious in config to change.

n.b.. also posted in mozzilla support
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Damn, we missed a case and the "Correspondents" still show up even if disabled. Thanks for reporting.
Status: UNCONFIRMED → NEW
Ever confirmed: true
thanks for getting to it quickly.. will look forward to the patch
Attached patch Fix (v1).Splinter Review
Same as:
https://dxr.mozilla.org/comm-central/source/mailnews/db/gloda/modules/dbview.js#125
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Attachment #8759863 - Flags: review?(acelists)
(In reply to nancy.lobaugh from comment #2)
> thanks for getting to it quickly.. will look forward to the patch
If you like the service, make a donation ;-)
https://donate.mozilla.org/en-US/thunderbird/about/
Comment on attachment 8759863 [details] [diff] [review]
Fix (v1).

Review of attachment 8759863 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, works for me.
Attachment #8759863 - Flags: review?(acelists) → review+
https://hg.mozilla.org/comm-central/rev/d1ef2c748662

Another act in the drama of the correspondents column ;-(
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0
Comment on attachment 8759863 [details] [diff] [review]
Fix (v1).

[Approval Request Comment]
Regression caused by (bug #): one of the correspondent column bugs.
User impact if declined: Correspondent column still showing in advanced search.
Testing completed (on c-c, etc.): Manual.
Risk to taking this patch (and alternatives if risky):
Very low risk since it's the same code we already use in gloda search.

Kent, maybe slip this into TB 45.2?
Flags: needinfo?(rkent)
Attachment #8759863 - Flags: approval-comm-esr45?
Attachment #8759863 - Flags: approval-comm-beta?
Attachment #8759863 - Flags: approval-comm-aurora+
Duplicate of this bug: 1278073
"Kent, maybe slip this into TB 45.2?"

Although I agree this is low risk, at the same time the user impact is pretty low as well. Pushing bugs fast to uplift has its costs, and I don't see that the impact of this bug justifies the effort.

Can't we just follow our process (that would mean a fast uplift of this would be to 45.3, not 45.2, with an intervening beta)? Not everything has to be an exception.
Flags: needinfo?(rkent)
Comment on attachment 8759863 [details] [diff] [review]
Fix (v1).

Too late for TB 47 beta now.
Attachment #8759863 - Flags: approval-comm-beta?
Duplicate of this bug: 1283810
Attachment #8759863 - Flags: approval-comm-esr45? → approval-comm-esr45+
Following upgrade to TB 45.3.0, I see that the Correspondents column of the Advanced Search (Ctrl-Shift-F) results pane has been replaced by default with the From column.  But the Recipient column still fails to appear until I manually select it each time I bring up the Advanced Search pane.  Wasn't the intent of the fix to this bug to allow BOTH the From and Recipient columns to appear instead of the Correspondents column?  I do need to see them both for my use of Advanced Search and would prefer to not have to add the Recipient column every time I bring up Advanced Search.
We restored the original behaviour of TB 38 which only showed the From column.
Isn't it reasonable to expect that the columns a user selects for the Advanced Search pane should remain in place as do the column selections for folders?  Would that have to be a new feature request?

By the way, I've just looked at the beta release for TB 49.0 and see that the Correspondents column still appears there in the Advanced Search pane even with mailnews.ui.upgrade.correspondents set to false.  Is this fix from TB 45.3.0 to get at least the From column back in that pane getting lost in TB 49.0?
(In reply to Vince at UpperBear from comment #16)
> Isn't it reasonable to expect that the columns a user selects for the
> Advanced Search pane should remain in place as do the column selections for
> folders?  Would that have to be a new feature request?
Yes.

> By the way, I've just looked at the beta release for TB 49.0 and see that
> the Correspondents column still appears there in the Advanced Search pane
> even with mailnews.ui.upgrade.correspondents set to false.  Is this fix from
> TB 45.3.0 to get at least the From column back in that pane getting lost in
> TB 49.0?
The option in TB 45.3 and 49 is called mail.threadpane.use_correspondents. Refer to:
https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_message-list-and-message-header
(In reply to Jorg K (GMT+2, PTO during summer) from comment #17)
> > By the way, I've just looked at the beta release for TB 49.0 and see that
> > the Correspondents column still appears there in the Advanced Search pane
> > even with mailnews.ui.upgrade.correspondents set to false.  Is this fix from
> > TB 45.3.0 to get at least the From column back in that pane getting lost in
> > TB 49.0?
> The option in TB 45.3 and 49 is called mail.threadpane.use_correspondents.
> Refer to:
> https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_message-list-and-
> message-header

I see that the default setting for mail.threadpane.use_correspondents in TB 45.3.0 is "false", but in TB 49.0 beta the default setting is "true".  Why is the Correspondents column coming back by default in TB 49.0?
(In reply to Vince at UpperBear from comment #18)
> I see that the default setting for mail.threadpane.use_correspondents in TB
> 45.3.0 is "false", but in TB 49.0 beta the default setting is "true".  Why
> is the Correspondents column coming back by default in TB 49.0?
The correspondents are switched of by default in TB 45.x. They will be back in later versions unless you switch them off.
re :RESOLVED FIXED in Thunderbird 49.0 

This implies this bug is/was fixed, but I've used every version and it is not fixed.
Now Using version 52.7.0
'Find' > 'Search Messages'
The 'Correspondents' column is still visible by default.
Whilst it can be manually removed and substitiuted with eg: From, this will only exist until you either close the search window or exit Thunderbird.

mail.threadpane.use_correspondents = false
set when first upgraded, but has no effect in search

mailnews.ui.upgrade.correspondents, created this and set to false, restarted TB but has no efect.

I'm using Vista OS, so limited in what Thunderbird versions are available from now onwards.

Is this bug still being worked on ?
Is there any chance this could be done for those stuck with versions for Vista ?
It's not being worked on, since it was fixed long ago.

I've just tested TB 52.7.

Edit > Find > Search messages: A window opens with a Correspondents column.
Now set pref mail.threadpane.use_correspondents to false. Repeat:
Edit > Find > Search messages: A window opens with a From column.

So I can't action this since it's working for me.
It was fixed. An upgrade must have reset it cuz that Corespondents BS showed back up for me too. In the Search when when I remove Corespondents and put in From it should be sticky. From that point on. Like other apps do. Not this you gotta find and change some obscure parameter.

HEY DEVELOPERS!!! LEAVE MY SETTINGS AS THEY WERE IN UPGRADES!!

But they won't listen. Mozilla developers never have in the past. They do what they want. What they like. I have found them to be very arrogant in that respect. They don't listen to the users.

And what's this my password is too short BS?! I use combinations of upper and lower case and numbers and symbols. Always have. More arrogance. This site does not contain National Secrets.

Here's my new password: M0reArr0gantBS!!
You need to log in before you can comment on or make changes to this bug.