Redirect the donation link in aboutDialog to https://donate.mozilla.org/thunderbird/about/

RESOLVED FIXED in Thunderbird 50.0

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mkmelin, Assigned: mkmelin)

Tracking

unspecified
Thunderbird 50.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird47 wontfix, thunderbird48 fixed, thunderbird49 fixed, thunderbird50 fixed, thunderbird_esr4547+ fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1272972 +++

As discussed in bug 1272972, we want the donation link to show you content in your own language.

Instead of https://donate.mozilla.org/en-US/thunderbird/about/ we should use https://donate.mozilla.org/thunderbird/about/ once https://github.com/mozilla/donate.mozilla.org/pull/1576 is in production.
Assignee

Comment 1

3 years ago
I'll hold off asking for review until the PR is in production.
Assignee

Comment 2

3 years ago
Comment on attachment 8759826 [details] [diff] [review]
bug1277948_donate_url.v2.patch

Review of attachment 8759826 [details] [diff] [review]:
-----------------------------------------------------------------

https://donate.mozilla.org/thunderbird/about/ is redirecting properly now
Attachment #8759826 - Flags: review?(rkent)
Comment on attachment 8759826 [details] [diff] [review]
bug1277948_donate_url.v2.patch

Review of attachment 8759826 [details] [diff] [review]:
-----------------------------------------------------------------

Yes looks good, compiled and ran and it worked fine.
Attachment #8759826 - Flags: review?(rkent) → review+
Assignee

Comment 4

3 years ago
https://hg.mozilla.org/comm-central/rev/4f9fcae55b38 -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 50.0
Assignee

Comment 5

3 years ago
Comment on attachment 8759826 [details] [diff] [review]
bug1277948_donate_url.v2.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Always go to en-US donate page instead of localized

We should fix this on esr, don't know if we care on the branches
Attachment #8759826 - Flags: approval-comm-esr45?
Attachment #8759826 - Flags: approval-comm-beta?
Attachment #8759826 - Flags: approval-comm-aurora?

Comment 6

3 years ago
Comment on attachment 8759826 [details] [diff] [review]
bug1277948_donate_url.v2.patch

I care about the branches. The uplift train runs every weekend ;-)
Attachment #8759826 - Flags: approval-comm-beta?
Attachment #8759826 - Flags: approval-comm-beta+
Attachment #8759826 - Flags: approval-comm-aurora?
Attachment #8759826 - Flags: approval-comm-aurora+
Comment on attachment 8759826 [details] [diff] [review]
bug1277948_donate_url.v2.patch

Although this did not make beta 47, it is easy to test manually, and the impact on failure is less than the impact on success. So let's take it for esr45.2
Attachment #8759826 - Flags: approval-comm-esr45? → approval-comm-esr45+
You need to log in before you can comment on or make changes to this bug.