Closed Bug 1277996 Opened 6 years ago Closed 4 years ago

flash process crashes in mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::plugins::PPluginSurfaceChild::Write

Categories

(Core Graveyard :: Plug-ins, defect, P5)

Unspecified
Windows 7
defect

Tracking

(firefox49+ wontfix, firefox50- unaffected)

RESOLVED WONTFIX
Tracking Status
firefox49 + wontfix
firefox50 - unaffected

People

(Reporter: dbaron, Unassigned)

References

Details

(Keywords: crash, topcrash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-a41ef1fd-5edf-4eef-83ea-020ea2160603.
=============================================================

These crashes with signature mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::plugins::PPluginSurfaceChild::Write are quite common, and are now showing up as a result of infobar crash submission (bug 1269998).

They're *mostly* (but appparently not entirely, maybe the metadata are wrong!?) crashes in the plugin process, and the plugin is Flash in all but one case.

Who should own these?
Flags: needinfo?(jmathies)
Flags: needinfo?(benjamin)
AFAICT we're trying to send a delete message for a PluginSurfaceChild on a channel that has already experienced an error. We probably shouldn't do that.

Owners would be myself or benjamin.
Flags: needinfo?(jmathies)
Duplicate of this bug: 1278159
bug 1268559 may help here.
Assuming that these all have PPluginModuleChild::OnChannelError farther up the stack, this particular crash is very low priority. We've already detected a channel error and should just be aborting the child process without doing any of this work which happens to crash.
Flags: needinfo?(benjamin)
Priority: -- → P5
This is the #1 topcrash on aurora 49 with 733 crashes in the last week, 8.3% of aurora crashes. So I am a bit worried about the volume we are seeing in crash-stats.
369 crashes in the last week across all channels - http://bit.ly/29lTyND - 197 on Aurora and 189 on Nightly. So we are definitely not seeing quite the volume we were back in June.
Hi :bsmedberg,
There are still some crashes in 49.0b1 but the volume is low, do you think we can have someone to help on this?
Flags: needinfo?(benjamin)
No. That's why I marked it P5 in the first place.
Flags: needinfo?(benjamin)
Mark this as fix-optional for 49 as this is low priority.
It doesn't look like 50 is affected, no crashes reported recently.
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.