Mouse sometimes not within element for purposes of mouseenter/mouseleave when it's within SVG elements

RESOLVED DUPLICATE of bug 577785

Status

()

defect
RESOLVED DUPLICATE of bug 577785
3 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({testcase})

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome][parity-webkit], )

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36

Steps to reproduce:

1. Open http://codepen.io/cvrebert/pen/RajVGb in Firefox
2. Hover the mouse pointer over a black square.
3. Hover over the white area between the black squares.
4. (Optionally) repeat steps 2 & 3 multiple times.


Actual results:

When hovering over the white area, a tooltip is shown.
When hovering over a black area, the tooltip is hidden.
This happens because mouseleave events are dispatched (supposedly indicating that the pointer has left the blue square)
whenever the pointer hovers over one of the black squares.


Expected results:

When hovering anywhere (including the black squares) within the bounds of the blue square, a tooltip should be shown and should remain shown until the pointer leaves the blue square.

This is the behavior exhibited by Chrome and Safari.
I have no idea what the specs mandate here.
Original Bootstrap bug: https://github.com/twbs/bootstrap/issues/19670

I also note that Firefox's inspector shows the <use>'s size as 320x320,
whereas it's 80x80 in Chrome and Safari. Perhaps this is a factor?
Blocks: 1230801
Keywords: testcase
OS: Unspecified → All
Hardware: Unspecified → All
Whiteboard: [parity-chrome][parity-webkit]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577785
No longer blocks: 1230801
You need to log in before you can comment on or make changes to this bug.