Closed Bug 1278042 Opened 4 years ago Closed 3 years ago

OSX Build error with disable-updater build option set

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set

Tracking

(firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: mozilla, Assigned: mkaply)

Details

Attachments

(1 file)

Built with
  ac_add_options --disable-updater
in .mozconfig on OSX (10.11.6 El Capitan Beta 15G7a)

Since https://hg.mozilla.org/mozilla-central/rev/0cd11745dc45, mach build fails with error:
 3:06.88 mv: rename ../../dist/Firefox.app/Contents/MacOS/updater.app/Contents/MacOS/org.mozilla.updater to ../../dist/Firefox.app/Contents/Library/LaunchServices/org.mozilla.updater: No such file or directory
and mach package fails with:
 0:01.03 Error: /Users/sswindells/mozilla-central/browser/installer/package-manifest.in:38: Missing file(s): Firefox.app/Contents/Library/LaunchServices

Looks like a regression introduced by #394984.

Removing the LaunchServices references in lines 91/92 in browser/app/Makefile.in and line 38 in browser/installer/package-manifest.in fix build and package respectively.
Confirming.
Assignee: nobody → mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 8851605 [details]
Bug 1278042 - If update is disabled, don't copy LaunchServices.

https://reviewboard.mozilla.org/r/123874/#review126350

This seems to be missing the changes to package-manifest.in. Looks good otherwise. Thanks!
Attachment #8851605 - Flags: review?(spohl.mozilla.bugs) → review-
Comment on attachment 8851605 [details]
Bug 1278042 - If update is disabled, don't copy LaunchServices.

https://reviewboard.mozilla.org/r/123874/#review126364

Thank you!
Attachment #8851605 - Flags: review?(spohl.mozilla.bugs) → review+
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/87e9ff6e13c5
If update is disabled, don't copy LaunchServices. r=spohl
https://hg.mozilla.org/mozilla-central/rev/87e9ff6e13c5
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 55 → mozilla55
You need to log in before you can comment on or make changes to this bug.