Closed Bug 1278086 Opened 4 years ago Closed 4 years ago

Autophone - update production test manifests for better try coverage

Categories

(Testing :: Autophone, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bc, Assigned: bc)

References

Details

Attachments

(2 files)

Currently we are missing some try coverage on nexus 4 and try coverage for nexus s is split between nexus-s-3, nexus-s-8 and nexus-s-9. In addition, in bug 1275272 we moved nexus-6p-8 to try for rca to see if repeated rca tests were causing the disconnections. It does appear to be the case that rca tests were the cause. We also remove rca on try from nexus-6p-8 since we don't want it to be possible for the device to be disconnected via a try run. nexus-6p-7 already has coverage for rca.

Improve try coverage for nexus 4 on nexus-4-7
Move all try coverage for nexus s to nexus-s-8
Remove rca try from nexus-6p-8.
Attachment #8760020 - Flags: review+
Attached file test-manifest.txt
nexus-4-7 nexus 4 device dedicated for try
nexus-5-6 nexus 5 device dedicated for try
nexus-s-8 nexus s device dedicated for try
nexus-6p-7 nexus 6p device dedicated for try

nexus-6-2 nexus 6 device for try but also runs other tests.
nexus-9-2 nexus 9 device for try but also runs other tests.
nexus-6p-{1,2} runs try talos in addition to production talos.

With this arrangement, the nexus s, 4, 5, 6p devices ability to run production tests is unaffected by try runs.
https://github.com/mozilla/autophone/commit/f0d04843137c72f246a20bcdd4c3bc4452ea3d44
deployed 2016-06-04 17:00:00
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.