Closed Bug 12782 Opened 20 years ago Closed 20 years ago

Crash: clicking on text field

Categories

(Core :: User events and focus handling, defect, P3)

x86
All
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jmaline, Assigned: joki)

Details

(Keywords: crash, verifyme, Whiteboard: [testcase])

Attachments

(1 file)

My build of M9 on redhat 6 crashes when I click on a particular text field.  It
started out as the web e-mail interface for my ISP, but I've cut the example
down fairly small.

To reproduce:  Save attached html to a file.  Load with
file:/the/file/you/saved/to.  Click on the text field.

Oh, as a secondary bug, the text value in this field should display but doesn't.

Here's the stack trace I get when running in gdb...

#0  0x40e11a13 in nsEventStateManager::SendFocusBlur (this=0x854eda0,
    aContent=0x8172aec) at nsEventStateManager.cpp:1257
#1  0x40e1127a in nsEventStateManager::SetContentState (this=0x854eda0,
    aContent=0x8172aec, aState=2) at nsEventStateManager.cpp:1126
#2  0x40e98ae1 in nsHTMLInputElement::SetFocus (this=0x8172ae0,
    aPresContext=0x853bca8) at nsHTMLInputElement.cpp:432
#3  0x40e101d0 in nsEventStateManager::ChangeFocus (this=0x854eda0,
    aFocus=0x8172aec, aSetFocus=1) at nsEventStateManager.cpp:783
#4  0x40e0eea5 in nsEventStateManager::PostHandleEvent (this=0x854eda0,
    aPresContext=@0x853bca8, aEvent=0xbffff4e0, aTargetFrame=0x830ba20,
    aStatus=@0xbffff454, aView=0x82bb220) at nsEventStateManager.cpp:242
#5  0x40e4f4ed in PresShell::HandleEvent (this=0x8520c28, aView=0x82bb220,
    aEvent=0xbffff4e0, aEventStatus=@0xbffff454) at nsPresShell.cpp:1882
#6  0x41bd0b43 in nsView::HandleEvent (this=0x82bb220, event=0xbffff4e0,
    aEventFlags=8, aStatus=@0xbffff454, aHandled=@0xbffff3f8) at nsView.cpp:834
#7  0x41bd0ad2 in nsView::HandleEvent (this=0x81b6588, event=0xbffff4e0,
    aEventFlags=8, aStatus=@0xbffff454, aHandled=@0xbffff3f8) at nsView.cpp:818
#8  0x41bd0ad2 in nsView::HandleEvent (this=0x852c9c0, event=0xbffff4e0,
    aEventFlags=8, aStatus=@0xbffff454, aHandled=@0xbffff3f8) at nsView.cpp:818
#9  0x41bd0ad2 in nsView::HandleEvent (this=0x85d2860, event=0xbffff4e0,
    aEventFlags=8, aStatus=@0xbffff454, aHandled=@0xbffff3f8) at nsView.cpp:818
#10 0x41bd0ad2 in nsView::HandleEvent (this=0x8628928, event=0xbffff4e0,
    aEventFlags=28, aStatus=@0xbffff454, aHandled=@0xbffff3f8)
    at nsView.cpp:818
#11 0x41bd9e33 in nsViewManager::DispatchEvent (this=0x852f688,
    aEvent=0xbffff4e0, aStatus=@0xbffff454) at nsViewManager.cpp:1609
#12 0x41bcec64 in HandleEvent (aEvent=0xbffff4e0) at nsView.cpp:66
#13 0x4004b002 in nsWidget::DispatchEvent (this=0x82bb288, event=0xbffff4e0,
    aStatus=@0xbffff490) at nsWidget.cpp:1186
#14 0x4004ad2c in nsWidget::DispatchWindowEvent (this=0x82bb288,
    event=0xbffff4e0) at nsWidget.cpp:1050
#15 0x4004b0c0 in nsWidget::DispatchMouseEvent (this=0x82bb288,
    aEvent=@0xbffff4e0) at nsWidget.cpp:1213
#16 0x4004be26 in nsWidget::OnButtonPressSignal (this=0x82bb288,
    aGdkButtonEvent=0x853bf40) at nsWidget.cpp:1763
#17 0x4004c91e in nsWidget::ButtonPressSignal (aWidget=0x8544510,
    aGdkButtonEvent=0x853bf40, aData=0x82bb288) at nsWidget.cpp:2142
#18 0x404bc79d in gtk_marshal_BOOL__POINTER ()
#19 0x40484037 in gtk_handlers_run ()
#20 0x4048352f in gtk_signal_real_emit ()
#21 0x40481800 in gtk_signal_emit ()
#22 0x404b45b8 in gtk_widget_event ()
#23 0x404591a2 in gtk_propagate_event ()
#24 0x404584da in gtk_main_do_event ()
#25 0x404fcab2 in gdk_event_dispatch ()
#26 0x405292c6 in g_main_dispatch ()
#27 0x40529801 in g_main_iterate ()
#28 0x40529979 in g_main_run ()
#29 0x40457f3a in gtk_main ()
#30 0x40038329 in nsAppShell::Run (this=0x80cd598) at nsAppShell.cpp:371
#31 0x40787501 in nsAppShellService::Run (this=0x80c5a08)
    at nsAppShellService.cpp:470
#32 0x804be45 in main1 (argc=1, argv=0xbffffb84) at nsAppRunner.cpp:761
#33 0x804bfff in main (argc=1, argv=0xbffffb84) at nsAppRunner.cpp:828
#34 0x40682cb3 in __libc_start_main (main=0x804bf9c <main>, argc=1,
    argv=0xbffffb84, init=0x804a7c8 <_init>, fini=0x804e34c <_fini>,
    rtld_fini=0x4000a350 <_dl_fini>, stack_end=0xbffffb7c)
    at ../sysdeps/generic/libc-start.c:78



Here's the html file...

<HTML>
<HEAD>
<TITLE>Reading message 1 of 1</TITLE>
</HEAD>
<TABLE WIDTH=100% BORDER=0 CELLPADDING=0>
<TR><TD>
<FORM ACTION="http://my.flash.net/mail/myfn_mail_112.cgi?replymail" METHOD=POST>
<INPUT TYPE=HIDDEN NAME="num" VALUE="1">
<INPUT TYPE=HIDDEN NAME="username" VALUE="jmaline">
<INPUT TYPE=HIDDEN NAME="from" VALUE="jmaline@flash.net">
<INPUT TYPE=HIDDEN NAME="subject" VALUE="x">
<INPUT TYPE=HIDDEN NAME="date" VALUE="Sun Aug 29 22:32:38 1999">
<INPUT TYPE=HIDDEN NAME="username" VALUE="jmaline">
<SELECT NAME="action">
<OPTION VALUE="reply">Reply to
<OPTION VALUE="forward">Forward
<OPTION VALUE="redirect">Redirect
</SELECT>
<INPUT TYPE=TEXT NAME="reply" VALUE="jmaline@flash.net" onFocus="this.blur()"
SIZE=35>
<INPUT TYPE=SUBMIT NAME=submit VALUE=Compose>
<INPUT TYPE=HIDDEN NAME="body" VALUE="testing 2


">
</FORM>
</TD>
</TR>
</TABLE>
</BODY>
</HTML>
OS: Linux → All
Summary: M9 crash on clicking on text field → Crash: clicking on text field
Whiteboard: [testcase]
This occurs on all platforms, and is still present in post-m9 builds.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
The fix I checked in today should over this.
Status: RESOLVED → REOPENED
I refreshed my build on the evening of sep 29 and sep 30.  Both times I still
see the problem
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen of this bug.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Oops.  Chalk the re-open up to CVS mishap.  I was running the old code (freshly
re-compiled though!).
Keywords: verifyme
Adding crash keyword
Keywords: crash
verified with 062308 builds win32 (NT) and Mac OS9
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.