Impossible to install an add-on from file on Windows with BlueGriffon

RESOLVED DUPLICATE of bug 1277295

Status

()

--
critical
RESOLVED DUPLICATE of bug 1277295
2 years ago
2 years ago

People

(Reporter: glazou, Unassigned)

Tracking

Trunk
All
Windows
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(Reporter)

Description

2 years ago
So this weird bug happens with my BlueGriffon 2.0 builds but only
on Windows... Linux and OSX seem to be unaffected and I don't really
know why. Anyway... Installing an add-on (like FireFtp from file
with BlueGriffon 2.0 on Windows triggers the following error, after
restart of the application:

  1465214081335       addons.xpi      ERROR   Unable to read add-on manifest from C:\Users\glazou\AppData\Roaming\Disruptive Innovations SARL\BlueGriffon\Profiles\adencof5.default\extensions\staged\{a7c6cf7f-112c-4500-a7ea-39801a327e5f}.xpi: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 230"  data: no] Stack trace: XPCU_serviceLambda()@resource://gre/modules/XPCOMUtils.jsm:230 < XPCU_defineLazyGetter/<.get()@resource://gre/modules/XPCOMUtils.jsm:198 < defineSyncGUID()@resource://gre/modules/addons/XPIProvider.jsm:1215 < loadManifestFromZipReader<()@resource://gre/modules/addons/XPIProvider.jsm:1396 < TaskImpl_run()@resource://gre/modules/Task.jsm:319 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816

This appears to be triggered by

   let storage = Services.storage;

in XPIProvider.jsm at [1].

Just encapsulating this single line in a try/catch fixes the
issue. Good enough for me and BlueGriffon but this probably
deserves a better fix in mozilla-central.

[1] http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#1229
This suggests that the sqlite storage service isn't available which is odd. How is BlueGriffon built? Is it based on XULRunner or are you building gecko from scratch?
Flags: needinfo?(daniel)
(Reporter)

Comment 2

2 years ago
(In reply to Dave Townsend [:mossop] from comment #1)
> This suggests that the sqlite storage service isn't available which is odd.
> How is BlueGriffon built? Is it based on XULRunner or are you building gecko
> from scratch?

Yes, from scratch. But sqlite *is* available, and a lot of my BlueGriffon-
specific code relies on it and works beautifully. For what I see, it's just
not available *yet* when that line is executed and when an add-on is
postinstalled at startup...
Flags: needinfo?(daniel)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277295
You need to log in before you can comment on or make changes to this bug.