Closed Bug 1278341 Opened 3 years ago Closed 2 years ago

Bootstrap's "Please choose the version of Firefox you want to build" prompt has so much text, its list of options are scrolled offscreen

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox49 affected, firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox49 --- affected
firefox57 --- fixed

People

(Reporter: dholbert, Assigned: wgianopoulos)

References

Details

Attachments

(2 files, 1 obsolete file)

STR:
 1. Run the one-line-setup script from https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Mac_OS_X_Prerequisites

i.e. run this command:
curl https://hg.mozilla.org/mozilla-central/raw-file/default/python/mozboot/bin/bootstrap.py > bootstrap.py && python bootstrap.py

 2. Step through the commands until you get to the "Firefox for Android" question.

ACTUAL RESULTS:
If you're using a default-sized Mac terminal window, you'll see this prompt in your terminal:
===========
3. Firefox for Android

Note: (For Firefox for Android)

The Firefox for Android front-end is built using Java, the Android
Platform SDK, JavaScript, HTML, and CSS. If you want to work on the
look-and-feel of Firefox for Android, you want "Firefox for Android
Artifact Mode".

Firefox for Android is built on top of the Gecko technology
platform. Gecko is Mozilla's web rendering engine, similar to Edge,
Blink, and WebKit. Gecko is implemented in C++ and JavaScript. If you
want to work on web rendering, you want "Firefox for Android".

If you don't know what you want, start with just "Firefox for Android
Artifact Mode". Your builds will be much shorter than if you build
Gecko as well. But don't worry! You can always switch configurations
later.

You can learn more about Artifact mode builds at
https://developer.mozilla.org/en-US/docs/Artifact_builds.

Your choice:
===========

It is 100% unclear what the valid choices are for "Your choice". E.g. "No" or a blank response are not accepted.  IN FACT, you're supposed to pick 1, 2, or 3; those correspond to options that are listed at the top of this prompt. But only "3. Firefox for Android" fits in the terminal, and the other options are pushed offscreen because there's so much text.  So, the one option that's visible ends up just looking like a title of some sort.

EXPECTED RESULTS:
The choices should be listed closer to the actual prompt, so they're more likely to be visible alongside the prompt. And, there should perhaps be less text in the explanation anyway, so that the whole explanation can be visible & readable without need for scrolling/resizing.
Summary: Bootstrap's "Please choose the version of Firefox you want to build" prompt has too much text to show you the options → Bootstrap's "Please choose the version of Firefox you want to build" prompt has so much text, its list of options are scrolled offscreen
Here's a screenshot of approximately what this prompt looks like, for people running the bootstrap script on a Mac.

(I took the screenshot on my Linux machine, but the terminal in my screenshot is the same size as the default terminal size on Mac, at least on intern Jonathan Chan's brand new Mac machine.)
Attachment #8760416 - Attachment description: screenshot → screenshot (totally unclear what the user should type after "Your choice")
Looks like this text was added in bug 1221200, mentored by nalexander.

nalexander, see the attached screenshot for the problem here.  (1/2/3 choice-listing is pushed offscreen by all the text.) Could you perhaps take this, or suggest an appropriate rewriting/reordering of this prompt which someone else could implement?
Blocks: 1221200
Flags: needinfo?(nalexander)
(In reply to Daniel Holbert [:dholbert] from comment #2)
> Looks like this text was added in bug 1221200, mentored by nalexander.
> 
> nalexander, see the attached screenshot for the problem here.  (1/2/3
> choice-listing is pushed offscreen by all the text.) Could you perhaps take
> this, or suggest an appropriate rewriting/reordering of this prompt which
> someone else could implement?

Hmm.  I think we should move the note up, so that the choices and the prompt are co-located.  We might also move the note into the artifacts page, or otherwise separate this.  Alternately, we use $PAGER to display some of the "getting started" stuff.

I'm not going to get to this; redirecting to chmanchester.
Flags: needinfo?(nalexander) → needinfo?(cmanchester)
Nick's suggestion sounds reasonable. The relevant text is in python/mozboot/mozboot/bootstrap.py
Flags: needinfo?(cmanchester)
Duplicate of this bug: 1387724
Attached patch patch (obsolete) — Splinter Review
Attachment #8894213 - Flags: review?(nalexander)
Assignee: nobody → wgianopoulos
Status: NEW → ASSIGNED
Attached patch bug1278341.patchSplinter Review
Fix typo in checkin-comment.
Attachment #8894215 - Flags: review?(nalexander)
Attachment #8894213 - Attachment is obsolete: true
Attachment #8894213 - Flags: review?(nalexander)
Comment on attachment 8894215 [details] [diff] [review]
bug1278341.patch

Review of attachment 8894215 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, I noticed this myself on Windows.
Attachment #8894215 - Flags: review?(nalexander) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c102e5d5478
Move choices closer to prompt in mach bootstrap. r=nalexander
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0c102e5d5478
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.