Newsletter sign up success message tweaks

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jessilyn Davis, Assigned: craigcook)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [q3 sprint 2])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently when you submit any email signup form you get the message:

"Thanks! Please check your inbox to confirm your subscription.

You'll receive an email from mozilla@e.mozilla.org to confirm your subscription. If you don't see it, please check your spam filter. You must confirm your subscription to receive our newsletter."

(originally implemented in Bug 897206)

This copy needs to be tweaked so that it works for people who have to double opt-in or people who don't have to (b/c they've already opt-ed in before and are now single opt-in). Some people will need the prompt to check their inbox to confirm, some people will get a welcome email, other people, if they're already subscribed to this newsletter, will not get any email.
Hey Jessilyn-

Is this a copy bug?  If not, do you have final copy?  Does Pmac know what is happening here?  What is your timeline?  Is it Basket work or Bedrock work?

Thanks,
Jen
Flags: needinfo?(jdavis)
(Reporter)

Comment 2

2 years ago
> Is it Basket work or Bedrock work?

Bedrock. This is changing the copy that shows up for the form submission confirmation.


> Does Pmac know what is happening here?  

I'm cc'ing him here in case it's helpful. This isn't a Basket bug, but a front-end Bedrock bug.


> What is your timeline?  

Not a blocker to anything major, but an improvement that should be made for existing user experience. Sometime in Q3 would be nice.


> Is this a copy bug?  

It could be depending on how you'd like the work broken out. (1 bug for Copy? 1 bug for Bedrock dev? 1 bug for tracking?)


> If not, do you have final copy?  

No. This needs copy written for it.
Flags: needinfo?(jdavis)
This is either very easy or very not depending on how many messages we're talking about.

1) It's easy if you mean we need a single "thank you" message that works for all possible subscriber types.

2) It's not easy at all if we need to detect the kind of person with whom we're dealing and display the appropriate message.

So which is the request? If it's #2 then we'll need to decide on cost/benefit because it will cost performance and SFDC API call hits as well as bedrock dev time to get and then deal with the new information, and provide very little benefit IMHO.
(Reporter)

Comment 4

2 years ago
We're talking about #1:

We need a single "thank you" message that works for all possible subscriber types.
Hey Jessilyn-

Is your team providing copy?  Or do you need copy written?

Sorry this one is taking so long to triage.

-Jen
Flags: needinfo?(mjkelly)
Flags: needinfo?(jdavis)
(Reporter)

Comment 6

2 years ago
No worries. Copy needs to be written. There are 2 ways I can see it being handled:

1) Moz.org team

2) MJ writes copy as part of her durable team work & making the encryption signup process more seamless.
Flags: needinfo?(jdavis)

Comment 7

2 years ago
I think this should be doable by me / our team. Let me add it to our sprint planning.
Flags: needinfo?(mjkelly)
Let's talk to Eric and Mike, MJ, and see if you or Troy could get it done earlier/faster in the next sprint.
Flags: needinfo?(malexis)
Flags: needinfo?(erenaud)
Sent meeting request to Troy, MJ and malexis to hash this out on Friday 7/15
Flags: needinfo?(erenaud)
Whiteboard: [q3 sprint 2]
Per meeting on 7/15: Troy will manage the copy for this issue

Comment 11

2 years ago
Hey everyone

Here are some options for the revised messaging. It's a bit tricky trying to make this a universal message, but hopefully there is something here that works. Let me know.

https://docs.google.com/a/mozilla.com/document/d/1fXXy9XE7sQvR_rkSu8gnuIYH3qeLQ09oGjwJ8nK7TUU/edit?usp=sharing

Thanks,
Troy
Clearing my NI
Flags: needinfo?(malexis)
(Reporter)

Comment 13

2 years ago
Thanks, Troy! I'm not 100% sure the feedback/signoff process, and my role in said process, but I just added my 2 cents to the doc.

Comment 14

2 years ago
With no other comments, we are moving forward with this copy:

Thanks! If you haven’t previously confirmed a subscription to a Mozilla-related newsletter you may have to do so. Please check your inbox or your spam filter for an email from us.

Thanks,
Troy
(Assignee)

Comment 15

2 years ago
Created attachment 8775271 [details] [review]
Github pull request https://github.com/mozilla/bedrock/pull/4251

The work is complete but because the newsletter form appears on almost every page this string is in a shared lang file that prevents us from easily deploying the code changes without breaking l10n for most locales. 

Assuming this can wait a few more weeks before going to prod, we can start l10n now and push the changes when we have good coverage.
Assignee: nobody → craigcook.bugz
Status: NEW → ASSIGNED
(Assignee)

Comment 16

2 years ago
(In reply to Troy Palmer from comment #14)
> With no other comments, we are moving forward with this copy:
> 
> Thanks! If you haven’t previously confirmed a subscription to a
> Mozilla-related newsletter you may have to do so. Please check your inbox or
> your spam filter for an email from us.


For proper context, the old copy was:

HEADING: Thanks! Please check your inbox to confirm your subscription.
BODY: You'll receive an email from mozilla@e.mozilla.org to confirm your subscription. If you don't see it, check your spam filter. You must confirm your subscription to receive our newsletter.

And the new copy is:

HEADING: Thanks!
BODY: If you haven’t previously confirmed a subscription to a Mozilla-related newsletter you may have to do so. Please check your inbox or your spam filter for an email from us.

Comment 17

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/e75caf8d7f0e863abd2f61f2848a5a5ac9801c2c
[fix bug 1278380] Update newsletter thank you message

https://github.com/mozilla/bedrock/commit/a13a5b28ccc5658f1d5c5e123833cd65474eda0f
Merge pull request #4251 from craigcook/bug-1278380-newsletter-success-message

[fix bug 1278380] Update newsletter thank you message

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.