2,000 instances of "WARNING: NSPR_LOG_MODULES is deprecated." emitted from none during linux64 debug testing

RESOLVED FIXED in Firefox 50

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: erahm, Assigned: erahm)

Tracking

(Blocks 1 bug)

Trunk
mozilla50
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 fixed)

Details

Attachments

(1 attachment)

> 2010 WARNING: NSPR_LOG_MODULES is deprecated.

This warning [1] shows up in the following test suites:

>    120 - [TC] Linux64 mochitest-2 2
>     97 - [TC] Linux64 mochitest-chrome-1 c1
>     86 - [TC] Linux64 mochitest-clipboard-e10s cl
>     75 - [TC] Linux64 mochitest-chrome-3 c3
>     66 - [TC] Linux64 mochitest-clipboard cl
>     66 - [TC] Linux64 mochitest-browser-chrome-e10s-1 bc1
>     59 - [TC] Linux64 mochitest-browser-chrome-e10s-3 bc3
>     55 - [TC] Linux64 mochitest-browser-chrome-e10s-4 bc4
>     54 - [TC] Linux64 mochitest-browser-chrome-e10s-5 bc5
>     52 - [TC] Linux64 mochitest-browser-chrome-e10s-2 bc2
>     49 - [TC] Linux64 mochitest-plain-e10s-5 5
>     46 - [TC] Linux64 mochitest-browser-chrome-4 bc4
>     45 - [TC] Linux64 mochitest-plain-e10s-4 4
>     45 - [TC] Linux64 mochitest-browser-chrome-2 bc2
>     45 - [TC] Linux64 mochitest-plain-e10s-9 9
>     42 - [TC] Linux64 mochitest-plain-e10s-3 3
>     40 - [TC] Linux64 mochitest-plain-e10s-2 2
>     40 - [TC] Linux64 mochitest-5 5
>     39 - [TC] Linux64 mochitest-plain-e10s-1 1
>     39 - [TC] Linux64 mochitest-plain-e10s-6 6
>     39 - [TC] Linux64 mochitest-plain-e10s-7 7
>     39 - [TC] Linux64 mochitest-plain-e10s-10 10
>     38 - [TC] Linux64 mochitest-browser-chrome-1 bc1
>     36 - [TC] Linux64 mochitest-4 4
>     36 - [TC] Linux64 mochitest-plain-e10s-8 8
>     36 - [TC] Linux64 mochitest-chrome-2 c2
>     36 - [TC] Linux64 mochitest-3 3
>     34 - [TC] Linux64 mochitest-6 6
>     34 - [TC] Linux64 mochitest-browser-chrome-5 bc5
>     33 - [TC] Linux64 mochitest-8 8
>     32 - [TC] Linux64 mochitest-browser-chrome-6 bc6
>     31 - [TC] Linux64 mochitest-10 10
>     30 - [TC] Linux64 mochitest-browser-chrome-e10s-6 bc6
>     30 - [TC] Linux64 mochitest-media-e10s mda
>     29 - [TC] Linux64 mochitest-9 9
>     27 - [TC] Linux64 mochitest-1 1
>     26 - [TC] Linux64 mochitest-7 7
>     24 - [TC] Linux64 mochitest-media mda
>     24 - [TC] Linux64 mochitest-browser-chrome-3 bc3
>     20 - [TC] Linux64 mochitest-gpu-e10s gpu
>     19 - [TC] Linux64 mochitest-browser-chrome-e10s-7 bc7
>     14 - [TC] Linux64 mochitest-gpu gpu
>     14 - [TC] Linux64 mochitest-devtools-chrome-5 dt5
>     12 - [TC] Linux64 mochitest-gl-e10s gl
>      9 - [TC] Linux64 mochitest-devtools-chrome-8 dt8
>      8 - [TC] Linux64 mochitest-gl gl
>      8 - [TC] Linux64 mochitest-devtools-chrome-7 dt7
>      8 - [TC] Linux64 mochitest-devtools-chrome-4 dt4
>      8 - [TC] Linux64 mochitest-devtools-chrome-3 dt3
>      8 - [TC] Linux64 mochitest-devtools-chrome-6 dt6
>      6 - [TC] Linux64 mochitest-devtools-chrome-2 dt2
>      6 - [TC] Linux64 reftest-e10s-3 R-e10s3
>      6 - [TC] Linux64 mochitest-devtools-chrome-1 dt1
>      6 - [TC] Linux64 reftest-noaccel-e10s-3 Ru3
>      5 - [TC] Linux64 crashtest e10s C
>      5 - [TC] Linux64 reftest-3 R3
>      5 - [TC] Linux64 mochitest-a11y a11y
>      5 - [TC] Linux64 reftest-3 Ru3
>      4 - [TC] Linux64 crashtest C
>      4 - [TC] Linux64 mochitest-browser-chrome-7 bc7
>      3 - [TC] Linux64 reftest-e10s-6 R-e10s6
>      3 - [TC] Linux64 reftest-noaccel-e10s-6 Ru6
>      2 - [TC] Linux64 reftest-6 R6
>      2 - [TC] Linux64 mochitest-devtools-chrome-9 dt9
>      2 - [TC] Linux64 reftest-e10s-5 R-e10s5
>      2 - [TC] Linux64 reftest-e10s-4 R-e10s4
>      2 - [TC] Linux64 jsreftest e10s J
>      2 - [TC] Linux64 reftest-e10s-7 R-e10s7
>      2 - [TC] Linux64 reftest-noaccel-e10s-7 Ru7
>      2 - [TC] Linux64 reftest-noaccel-e10s-1 Ru1
>      2 - [TC] Linux64 reftest-e10s-8 R-e10s8
>      2 - [TC] Linux64 reftest-e10s-2 R-e10s2
>      2 - [TC] Linux64 mochitest-devtools-chrome-10 dt10
>      2 - [TC] Linux64 reftest-noaccel-e10s-5 Ru5
>      2 - [TC] Linux64 mochitest-jetpack JP
>      2 - [TC] Linux64 reftest-e10s-1 R-e10s1
>      2 - [TC] Linux64 reftest-noaccel-e10s-8 Ru8
>      2 - [TC] Linux64 reftest-noaccel-e10s-4 Ru4
>      2 - [TC] Linux64 reftest-6 Ru6
>      2 - [TC] Linux64 reftest-noaccel-e10s-2 Ru2
>      1 - [TC] Linux64 reftest-5 Ru5
>      1 - [TC] Linux64 reftest-5 R5
>      1 - [TC] Linux64 jsreftest J1
>      1 - [TC] Linux64 jsreftest J2
>      1 - [TC] Linux64 reftest-1 R1
>      1 - [TC] Linux64 reftest-4 Ru4
>      1 - [TC] Linux64 reftest-8 R8
>      1 - [TC] Linux64 reftest-2 R2
>      1 - [TC] Linux64 reftest-1 Ru1
>      1 - [TC] Linux64 reftest-2 Ru2
>      1 - [TC] Linux64 reftest-7 R7
>      1 - [TC] Linux64 reftest-7 Ru7
>      1 - [TC] Linux64 reftest-4 R4
>      1 - [TC] Linux64 reftest-8 Ru8

It shows up in 326 tests. A few of the most prevalent:

>    732 -        Shutdown
>    729 - [e10s] Shutdown
>     13 - [e10s] browser/components/sessionstore/test/browser_crashedTabs.js
>      8 -        browser/base/content/test/chat/browser_chatwindow.js
>      7 - [e10s] browser/components/customizableui/test/browser_967000_button_sync.js
>      7 -        browser/base/content/test/chat/browser_focus.js
>      6 - [e10s] browser/base/content/test/general/browser_aboutTabCrashed.js
>      4 -        dom/base/test/chrome/test_swapFrameLoaders.xul
>      3 -        toolkit/components/aboutmemory/tests/test_memoryReporters2.xul
>      3 -        toolkit/components/aboutmemory/tests/test_dumpGCAndCCLogsToFile.xul

[1] https://hg.mozilla.org/mozilla-central/annotate/0a3b6e2df656/none#l0
Ralph, it looks like the NSPR_LOG_MODULES deprecation warning is getting triggered during testing in mochitest, reftest, jsreftest, crashtest.
Flags: needinfo?(giles)
So, I fear some of these are unavoidable while we still have code using NSPR_LOG_MODULES (including nspr itself, but also in e.g. the webrtc code). I thought I got everything else in-tree, but maybe some of these are in out-of-tree harness code.

If it's causing problems I can remove the deprecation warning. What do you think?
Flags: needinfo?(giles) → needinfo?(erahm)
(In reply to Ralph Giles (:rillian) needinfo me from comment #2)
> So, I fear some of these are unavoidable while we still have code using
> NSPR_LOG_MODULES (including nspr itself, but also in e.g. the webrtc code).
> I thought I got everything else in-tree, but maybe some of these are in
> out-of-tree harness code.
> 
> If it's causing problems I can remove the deprecation warning. What do you
> think?

Maybe it's this? https://dxr.mozilla.org/mozilla-central/rev/3e8ee3599a67edd971770af4982ad4b0fe77f073/build/automation.py.in#247

Leaving the warning is fine as long as we can fix the tests.
Flags: needinfo?(erahm)
How can I record output from NSPR/NSS without using NSPR_LOG_MODULES? Mozilla logger shouldn't blindly warn the existence of the environment variable.
NSPR_LOG_MODULES is deprecated in favor of MOZ_LOG, this cleans up warning
spam during testing.
Attachment #8761416 - Flags: review?(ted)
Assignee: nobody → erahm
Status: NEW → ASSIGNED
Confirmed fixed in the try push from comment 6:

> 0 instances of "WARNING: NSPR_LOG_MODULES is deprecated." emitted from none during linux64 debug testing
Attachment #8761416 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/bf68f7b3de15
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.