Closed Bug 1278440 Opened 6 years ago Closed 4 years ago

Crash in js::TraceManuallyBarrieredEdge<T>

Categories

(Core :: JavaScript: GC, defect, P3)

x86
Windows
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox48 --- wontfix
firefox49 --- wontfix
firefox-esr45 --- wontfix
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- wontfix

People

(Reporter: ting, Unassigned)

References

Details

(Keywords: crash, triage-deferred)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-cceedcd1-842a-4b00-b64a-cb0da2160605.
=============================================================

#7 on Linux Nightly 20160605030215, 2 crashes from installation. But the first report was from v42.0, happened on both Windows and Linux.
(In reply to Ting-Yu Chou [:ting] from comment #0)
> #7 on Linux Nightly 20160605030215, 2 crashes from installation. But the

Correction: 2 crashes from 1 installation.

Note there have been 181 crashes since the first report.
From the minidump of 6d06bd0f-603a-4ee4-95a1-0f6bb2160603, *thingp is 0xe5e5e5e5. Terrence, do you have any ideas?
Flags: needinfo?(terrence)
0xe5 is the jemalloc freed memory pattern: it indicates either memory corruption (likely hardware) or a bug in some tracing code. If this signature is spiking and not just moving from another signature, it likely indicates that some new code in gecko is failing to trace a GC thing properly, either by failing to use the CC macros or by failing to ExposeToActiveJS when reading. If the signature is moved from another signature, then it is probably just part of the noise floor of semi-broken hardware floating around out in the wild.
Flags: needinfo?(terrence)
Crash volume for signature 'js::TraceManuallyBarrieredEdge<T>':
 - nightly (version 50): 29 crashes from 2016-06-06.
 - aurora  (version 49): 51 crashes from 2016-06-07.
 - beta    (version 48): 646 crashes from 2016-06-06.
 - release (version 47): 113 crashes from 2016-05-31.
 - esr     (version 45): 283 crashes from 2016-04-07.

Crash volume on the last weeks:
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       4       5       4       7       2       2       3
 - aurora        8       7       5       6       6       8       9
 - beta        172     168      17      19     175      32       4
 - release      14      15      13      12      15      19      18
 - esr          44      31      37      36      25      27      27

Affected platforms: Windows, Linux
Crash volume for signature 'js::TraceManuallyBarrieredEdge<T>':
 - nightly (version 51): 9 crashes from 2016-08-01.
 - aurora  (version 50): 17 crashes from 2016-08-01.
 - beta    (version 49): 258 crashes from 2016-08-02.
 - release (version 48): 851 crashes from 2016-07-25.
 - esr     (version 45): 422 crashes from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly       3       2       2
 - aurora        8       5       2
 - beta         49     129      46
 - release     257     261     150
 - esr          50      44      39

Affected platforms: Windows, Linux

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly           #153
 - aurora  #248      #761
 - beta    #339      #254
 - release #77       #125
 - esr     #182
Crash volume for signature 'js::TraceManuallyBarrieredEdge<T>':
 - nightly (version 52): 1 crash from 2016-09-19.
 - aurora  (version 51): 2 crashes from 2016-09-19.
 - beta    (version 50): 40 crashes from 2016-09-20.
 - release (version 49): 546 crashes from 2016-09-05.
 - esr     (version 45): 694 crashes from 2016-06-01.

Crash volume on the last weeks (Week N is from 10-03 to 10-09):
            W. N-1  W. N-2
 - nightly       0       1
 - aurora        1       1
 - beta         40       0
 - release     429     117
 - esr          81      66

Affected platforms: Windows, Linux

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly
 - aurora            #1111
 - beta    #546      #182
 - release #173      #109
 - esr     #139
Duplicate of this bug: 1151856
I've had a few crashes, and this is a freaking brand new hard drive.
Too late for firefox 52, mass-wontfix.
Keywords: triage-deferred
Priority: -- → P3
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Closing because no crashes reported for 12 weeks.
You need to log in before you can comment on or make changes to this bug.