If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Speaker button is missing from YouTube videos

RESOLVED INVALID

Status

()

Firefox for Android
Audio/Video
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: sorina, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox48 affected, firefox49 affected, fennec48+, firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Environment: 
Device: Asus Transformer Pad (Android 4.2.1);
Build: Nightly 50.0a1 (2016-06-07);

Steps to reproduce:
1. Go to wwww.youtube.com and play any video;
2. Tap the video to show the video controls.

Expected result:
Speaker button is displayed near full-screen button.

Actual result:
Speaker button is missing.

Comment 1

a year ago
Is this a regression from bug 1065076? Ray, can you look into this?
tracking-fennec: --- → ?
Flags: needinfo?(ralin)

Comment 2

a year ago
I can not reproduce this on LG G2 (Android 6). Perhaps it is a tablet only issue, but I don't have other devices in hand. 

:sorina, could you provide me a screenshot? Thanks
Flags: needinfo?(ralin)
(Reporter)

Comment 3

a year ago
Created attachment 8762078 [details]
Screenshot_2016-06-10-18-08-22.jpg
That's YouTube's own UI. Maybe break by a Platform change?

Comment 5

a year ago
Blake, could this be a platform problem like Tim mentioned?
tracking-fennec: ? → 48+
Flags: needinfo?(bwu)
(In reply to :Margaret Leibovic from comment #5)
> Blake, could this be a platform problem like Tim mentioned?
I have no idea that any platform change can cause this problem. 
Let's set regressionwindow-wanted and narrow down the root cause.
Flags: needinfo?(bwu)
Keywords: regressionwindow-wanted
Sorina,
Can you help check which version starts to have this problem?
Flags: needinfo?(sorina.florean)
I can see this problem on my ASUS Transformer Pad with released version (Firefox 47) on Android 4.4.2. 
So it seems this problem has existed for a while.
(Reporter)

Comment 9

a year ago
Tested using Asus Transformer Pad (Android 4.4.2) and Asus ZenPad 8 (Android 5.0.2).
I've tried to find a regression-window but I was unable to check on a build older than Nightly from 2013-06-01.
 On all the builds I was able to test the speaker button is not displayed near full-screen button.
Flags: needinfo?(sorina.florean)
Sorina,
Thanks for your help. 
I think it would be better to ask Youtube to help check what happens since it is their player.
blake: So this is solely in YouTube's control here?
Flags: needinfo?(bwu)
Mike: Is this something for webcompat?
Flags: needinfo?(miket)
Sebastian, 
I have asked Youtube and they said it is intended and on mobile web UI controls are sometimes removed so as not to compete with device-level functionality. Please check the mail I forwarded to you. 

I tested it on my tablet and speaker button does not show up on their Chrome on mobile either.
Flags: needinfo?(bwu)
Keywords: regressionwindow-wanted
Thanks! So this is working as intended (by YouTube).
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(miket)
Resolution: --- → INVALID
Thanks Blake!
You need to log in before you can comment on or make changes to this bug.