The webextension could not be installed

RESOLVED DUPLICATE of bug 1271831

Status

RESOLVED DUPLICATE of bug 1271831
2 years ago
2 months ago

People

(Reporter: vasilica.mihasca, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox47 unaffected, firefox48 affected, firefox49 affected, firefox50 affected)

Details

[Affected versions]:
Firefox 50.0a1 (2016-06-07)
Firefox 49.0a2 (2016-06-07)
Firefox 48.0a2 (2016-06-06)

[Affected platforms]:
Windows 10 64-bit
Ubuntu 14.04 32-bit
Mac OS X 10.11

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Create the xpinstall.signatures.dev-root pref in about:config and set it to true.
3.Install the following webextension:  https://addons-dev.allizom.org/en-US/firefox/addon/post-it-all-sticky-notes/


[Expected Results]:
The webextension is successfully installed.

[Actual Results]:
- The webextension could not be installed because it appears to be corrupted.
- The following error is thrown in Browser Console:
1465383894000	addons.webextension.<unknown>	ERROR	Loading extension 'null': Reading manifest: Error processing content_scripts.0.matches.2: Error processing content_scripts.0.matches.2: String "file://*" must match /^file:\/\/\/.*$/                                                Log.jsm:753


[Additional notes]:
- I am marking Firefox 47.0a2 (2016-04-17) as unaffected because the webextension cannot be installed on this Firefox version.

Comment 1

2 years ago
This is likely a dupe of bug 1271831 and will probably keep appearing because file:// is acceptable in Chrome. A ticket to block this in the linter would be appropriate.
Status: NEW → UNCONFIRMED
Ever confirmed: false

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271831

Updated

2 years ago
See Also: → bug 1244474

Updated

2 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.