Autophone - BuildLocation regexp should prevent prefix matches for builds

RESOLVED FIXED

Status

Testing
Autophone
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bc, Assigned: bc)

Tracking

(Blocks: 1 bug, {regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Sometime in the relatively recent past, additional files have been added to the dist output directory for Fennec builds. Each apk file now has a corresponding file with the extention .permissions added. For example,

fennec-50.0a1.en-US.android-arm.apk 
fennec-50.0a1.en-US.android-arm.apk.permissions

This causes problems with running Autophone against local builds since the current regexps do not anchor the match and inadvertently pick up the permissions file instead of the apk file.
(Assignee)

Comment 1

2 years ago
Created attachment 8761245 [details] [diff] [review]
bug-1278921-v1.patch
Attachment #8761245 - Flags: review?(jmaher)
Comment on attachment 8761245 [details] [diff] [review]
bug-1278921-v1.patch

Review of attachment 8761245 [details] [diff] [review]:
-----------------------------------------------------------------

I like small patches.
Attachment #8761245 - Flags: review?(jmaher) → review+
(Assignee)

Comment 3

2 years ago
https://github.com/mozilla/autophone/commit/0437b2f440646755276d9aa43a6aa6189817f1be
Blocks: 1157427
(Assignee)

Comment 4

2 years ago
deployed on autophone-2,3 2016-06-08 16:20. autophone-1 is dead, i'll deploy when it is resurrected.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.