compacting pop account with file/Compact Folders when account is selected, only when individual folder is selected

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
minor
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: DG12, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/601.6.17 (KHTML, like Gecko) Version/9.1.1 Safari/601.6.17

Steps to reproduce:

Menu File/Compact Folders is clicked.

Version 45.1.1


Actual results:

Multiple accounts, 1 is IMAP others POP.
If IMAP account is selected and menu file/Compact Folders is clicked many messages occur and it seems that the host files are compacted. NO other accounts are acted upon.

If one of the POP accounts is selected and Compact Folders is clicked NO ACTION IS TAKEN (no messages are displayed )

If one of the POP account FOLDERS is selected  and Compact Folders is clicked that FOLDER is successfully compacted and the associated .msf file is changed.


Expected results:

Regardless of the account or folder is currently selected all mailboxes should be compacted.

At the very least all folders within the account for the selected  account or should he account  of the selected folder should be compacted.
(Reporter)

Updated

2 years ago
Severity: normal → minor
(Reporter)

Updated

2 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64

Comment 1

2 years ago
(In reply to DG12 from comment #0)
> Multiple accounts, 1 is IMAP others POP.
> If IMAP account is selected and menu file/Compact Folders is clicked many
> messages occur and it seems that the host files are compacted. NO other
> accounts are acted upon.

correct. "Compact Folders" acts by design on only one account at a time.
 
> If one of the POP accounts is selected and Compact Folders is clicked NO
> ACTION IS TAKEN (no messages are displayed )
> 
> If one of the POP account FOLDERS is selected  and Compact Folders is
> clicked that FOLDER is successfully compacted and the associated .msf file
> is changed.

For my pop account, compact was successful whether I had the account or a folder selected. But (as expected) if there is nothing to compact, then the status bar will have nothing.

 
> Regardless of the account or folder is currently selected all mailboxes
> should be compacted.

this is bug 1077759
 
> At the very least all folders within the account for the selected  account
> or should he account  of the selected folder should be compacted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077759

Comment 2

2 years ago
DG12, 
Do you see anything on Tools | Error Console when you select account and compact?
And does this also reproduce if you have started Thunderbird in safe mode?
https://support.mozilla.org/en-US/kb/safe-mode
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(DG12)
Resolution: DUPLICATE → ---
Summary: compacting doesn't for file/Compact Folders unless individual folder is highlighted → compacting pop account with file/Compact Folders when account is selected, only when individual folder is selected
(Reporter)

Comment 3

2 years ago
In safe mode, expected mailboxes were compacted when selecting an account. Several messages (although the text says WARN)
20016-06-11 17:01:18 gloda.index_msg WARN Observed header that claims to be gloda indexed but that gloda has never heard of during compaction. in folder: mailbox://dgerman%40real0w-world-systems.com@mail.real-world-systems.com/1508 sketchy key:0 subject: Please join us for Brunch August 9
... sketchy key: 46198 subject ...
... 59432..707957...75005...86002...138727...164718...27221...
... InBox sketchy key:24 ...
... Sent sketchy key: 810

1508 is a subfolder 
Thank you for looking into this.
(Reporter)

Comment 4

2 years ago
Please see
http://real-world-systems.com/thunderbird/1508.trbl  
for the beginning of the 1508 file and
http://real-world-systems.com/thunderbird/1508.trbl.msf
for the beginning of the 1508.msf file

I will do additional testing to determine if failure still occurs in non-safe mode (with or without messages).
Flags: needinfo?(DG12)
(Reporter)

Comment 5

2 years ago
I am no longer able to reproduce the problem of selecting an account, then clicking on file/compact and having no folders compacted.

Thank you all for your assistance.

Comment 6

2 years ago
Thanks for the update.
What addons do you have installed?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

2 years ago
lightning extension installed and was enabled (now disabled)

Plugins installed but NOT active recently:
Adobe NPAPI 15.016.20045
Default Browser helper
Google Earth
Google Talk 5.41.3.0, Video Render 5.41.3.0
iPhotoPhotocase
Java Appet
NI LabView 2010 internet plugin for Mac
Shockwave Flash
Silverlight 5.1.20913.0
WebEx64 General Plugin Container 202
You need to log in before you can comment on or make changes to this bug.