Closed Bug 1279023 Opened 5 years ago Closed 5 years ago

Tapping push notification that says "You haven't closed the page, click here to focus it" does not re-focus the page

Categories

(Core :: DOM: Push Notifications, defect)

All
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1235431

People

(Reporter: Abe_LV, Unassigned)

References

(Blocks 1 open bug)

Details

In android devices, the Push Clients Demo page does not re-focus when notification is tapped. 

Steps to Reproduce:

1. Launch Firefox for Android on Android device	
2. Go to the Push Clients Demo page using https://serviceworke.rs/push-clients_demo.html
3. Press [Send notification] button
4. Switch to a new/different tab.
5. Swipe to access the notification. Notification should display 'you haven't closed the page, click here to focus'. 	
6. Tap on the notification to re-focus the Push Clients Demo.

Actual Result:

Push Clients Demo page is not re-focused.

Expected Result:

Push Clients Demo should be re-focused when the notification is tapped.
Flags: needinfo?(kcambridge)
Summary: Tapping push notification that says "You haven't closed the page, click here to focus it"does not focus the page → Tapping push notification that says "You haven't closed the page, click here to focus it" does not re-focus the page
Thanks, Abe!

Margaret or Catalin, do you know if we implement `ServiceWorkerWindowClient.focus()` on Android? I found bug 1248772, but it looks like the "DOMServiceWorkerFocusClient" event is only referenced in browser/base/content/tabbrowser.xml.
Component: Notifications and Alerts → DOM: Push Notifications
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(catalin.badea392)
Product: Toolkit → Core
Flags: needinfo?(kcambridge)
(In reply to Kit Cambridge [:kitcambridge] from comment #1)
> Thanks, Abe!
> 
> Margaret or Catalin, do you know if we implement
> `ServiceWorkerWindowClient.focus()` on Android? I found bug 1248772, but it
> looks like the "DOMServiceWorkerFocusClient" event is only referenced in
> browser/base/content/tabbrowser.xml.

No. ServiceWorkerWindowClient.focus() is currently broken because we don't handle the event on android.
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(catalin.badea392)
Blocks: 1269921
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235431
You need to log in before you can comment on or make changes to this bug.