Closed Bug 1279034 Opened 4 years ago Closed 4 years ago

[Disco Pane] Expose the abilty to enable/disable an add-on from content.

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla50
Iteration:
50.2 - Jul 4
Tracking Status
firefox48 + verified
firefox49 + verified
firefox50 --- verified

People

(Reporter: scolville, Assigned: aswan)

References

Details

Attachments

(1 file)

See https://github.com/mozilla/addons-frontend/issues/547 for context.

In the new discovery pane it's possible a user can disable the add-on external to discovery pane. When that happens we have no way to enable it as installation doesn't appear to change the disabled state.

We currently only need the ability to enable a disabled add-on.

I don't know if we are ever going to need to disable an addon but it might be worth adding it at the same time in case that was needed in the future.
Assignee: nobody → aswan
Blocks: 1245993
Status: NEW → ASSIGNED
Iteration: --- → 50.2
Comment on attachment 8765024 [details]
Bug 1279034 Add Addon.setEnabled() for a.m.o

https://reviewboard.mozilla.org/r/60570/#review57464
Attachment #8765024 - Flags: review?(rhelmer) → review+
Comment on attachment 8765024 [details]
Bug 1279034 Add Addon.setEnabled() for a.m.o

this is just a one-line webidl on an api that is only exposed to addons.mozilla.org but since it touches webidl it needs an r+ from a dom peer.
Attachment #8765024 - Flags: review?(bugs)
Attachment #8765024 - Flags: review?(bugs) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb9d3d2aa71d
Add Addon.setEnabled() for a.m.o r=rhelmer,smaug
[Tracking Requested - why for this release]:
This is part of the add-ons manager discovery pane revamp project, which is slated to go live in 48.
Comment on attachment 8765024 [details]
Bug 1279034 Add Addon.setEnabled() for a.m.o

Approval Request Comment
[Feature/regressing bug #]:
Add-ons Manager Discovery Pane

[User impact if declined]:
Described in complete detail at https://github.com/mozilla/addons-frontend/issues/547

[Describe test coverage new/current, TreeHerder]:
The patch adds new functionality and includes unit tests of that funcionality.

[Risks and why]: 
Risks are low, this functionality is only exposed to addons.mozilla.org.

[String/UUID change made/needed]:
none
Attachment #8765024 - Flags: approval-mozilla-beta?
Attachment #8765024 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/eb9d3d2aa71d
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
If its going to land in beta, we should land it in aurora.
Comment on attachment 8765024 [details]
Bug 1279034 Add Addon.setEnabled() for a.m.o

OK, let's take it to polish it.
Should be in 48 beta 5
Attachment #8765024 - Flags: approval-mozilla-beta?
Attachment #8765024 - Flags: approval-mozilla-beta+
Attachment #8765024 - Flags: approval-mozilla-aurora?
Attachment #8765024 - Flags: approval-mozilla-aurora+
I was able to reproduce the initial issue on Firefox 50.0a1 (2016-06-27) under windows 10 64-bit.
 
Verified fixed on Firefox 48.0.2 (20160823121617), Firefox 49 (20160912134115), Firefox 50.0a2 (2016-09-15) and Firefox 51.0a1 (2016-09-15) under Windows 10 64-bit and Ubuntu 16.04 32-bit. The add-on is successfully enabled from Disco Pane.
You need to log in before you can comment on or make changes to this bug.