Double clicking in the tab bar crashes firefox (xmonad required as window manager)

RESOLVED DUPLICATE of bug 1186967

Status

()

Core
Widget: Gtk
--
critical
RESOLVED DUPLICATE of bug 1186967
a year ago
7 months ago

People

(Reporter: A. Y., Unassigned)

Tracking

({crash})

47 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox48 affected, firefox49 affected, firefox-esr45 affected, firefox50 affected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160607080223

Steps to reproduce:

1. Start Firefox
2. Double click on the empty space on the tab bar


Actual results:

Firefox crashes with a segmentation fault.


Expected results:

A new tab should have opened.
(Reporter)

Comment 1

a year ago
Created attachment 8761471 [details]
Output printed to terminal

Comment 2

a year ago
Are you running the official Linux build from Mozilla?
If yes, is it reproducible with a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Severity: normal → critical
Flags: needinfo?(3yxzco+fg829jlk19u1k)
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 3

a year ago
Just tested with the official build with a fresh profile, was reproducible. Here is the crash report: https://crash-stats.mozilla.com/report/index/19ed74b8-9615-436b-9647-e98ca2160611

Comment 4

a year ago
Since FF46, Gtk3 is supported. Could it be related to that? Are you using a theme?
Blocks: 627699
Crash Signature: [@ mozalloc_abort | abort | libglib-2.0.so.0.4800.1@0x6f484 ]
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
(Reporter)

Comment 5

a year ago
Might have something to do with the window manager. The crash happens on xmonad 0.12 but not on i3 4.12.
Summary: Segfault when double clicking the tab bar → GTK 3.20.6 gdkwindow-x11.c:5147:create_moveresize_window: assertion failed: (mv_resize->moveresize_emulation_window == NULL) double clicking the tab bar

Comment 6

a year ago
This has been verified by a user on #firefox on freenode, he also run xmonad, we've verified it with:
http://ftp.mozilla.org/pub/firefox/releases/48.0/linux-x86_64/en-US/firefox-48.0.tar.bz2

and ran it with:
mkdir /tmp/test-profile ; ./firefox/firefox -no-remote -profile /tmp/test-profile

and crash report: bp-e0a649af-8919-485a-bae3-64f772160810

I can't reproduce it on mate, gnome-shell so xmonad sounds like a hard dependency.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: GTK 3.20.6 gdkwindow-x11.c:5147:create_moveresize_window: assertion failed: (mv_resize->moveresize_emulation_window == NULL) double clicking the tab bar → Double clicking in the tab bar crashes firefox (xmonad required as window manager)

Comment 7

a year ago
Reproduced on bspwm window manager.
https://crash-stats.mozilla.com/report/index/ac2519d3-e399-4f23-9619-965f02160810
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(3yxzco+fg829jlk19u1k)
Resolution: --- → DUPLICATE
Duplicate of bug: 1186967
Crash volume for signature 'mozalloc_abort | abort | libglib-2.0.so.0.4800.1@0x6f484':
 - nightly (version 51): 0 crashes from 2016-08-01.
 - aurora  (version 50): 27 crashes from 2016-08-01.
 - beta    (version 49): 12 crashes from 2016-08-02.
 - release (version 48): 3 crashes from 2016-07-25.
 - esr     (version 45): 4 crashes from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly       0       0       0
 - aurora        7      20       0
 - beta          0       0       0
 - release       0       2       1
 - esr           0       0       0

Affected platform: Linux

Crash rank on the last 7 days:
           Browser     Content   Plugin
 - nightly
 - aurora  #170
 - beta    #1267
 - release
 - esr
status-firefox48: --- → affected
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox-esr45: --- → affected
You need to log in before you can comment on or make changes to this bug.