Closed Bug 1279151 Opened 4 years ago Closed 4 years ago

_YASM_*_VERSION is not passed down from python configure to old-configure

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox49 fixed, firefox50 fixed)

VERIFIED FIXED
mozilla50
Tracking Status
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: gaston, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

My buildbot started failing on 19/5 with these errors:

http://buildbot.rhaalovely.net/builders/mozilla-central-amd64/builds/1734/steps/configure/logs/stdio

config.log online at http://rhaalovely.net/~landry/stuff/config.log

Of course i have yasm --version -> 1.3.0
It's a regression from bug 1269513
Blocks: 1269513
Before bug 1269513, yasm_version returned a Version object, and it
doesn't anymore, which made the assignment of _YASM_*_VERSION skipped
silently.

Then, configure would go through the yasm version checks as if they were
false and skipping over the AC_MSG_ERRORs, printing out:
/builds/slave/try-m64-0000000000000000000000/build/src/old-configure: line 19615: test: : integer expression expected

which is why this went undetected: the version checks were simply
ignored.

Some shells, however, evaluated the yasm version checks as true, hitting
the AC_MSG_ERRORs.

Review commit: https://reviewboard.mozilla.org/r/58650/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/58650/
Attachment #8761479 - Flags: review?(cmanchester)
Comment on attachment 8761479 [details]
Bug 1279151 - Version'ize the result of yasm_version.

mach configure now succeeds for me with this patch, thanks!
Attachment #8761479 - Flags: feedback+
Attachment #8761479 - Flags: review?(cmanchester) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/467c8c5d5fac
Version'ize the result of yasm_version. r=chmanchester
Comment on attachment 8761479 [details]
Bug 1279151 - Version'ize the result of yasm_version.

Approval Request Comment
[Feature/regressing bug #]: Regression from bug 1269513
[User impact if declined]: Build failing during configure because the yasm version check doesn't pass, or worse, fail later because it passes while it shouldn't have.
[Describe test coverage new/current, TreeHerder]: N/A
[Risks and why]: None. The patch is straightforward, and only affects the configure step of the build.
[String/UUID change made/needed]: N/A
Attachment #8761479 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/467c8c5d5fac
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Keywords: regression
Comment on attachment 8761479 [details]
Bug 1279151 - Version'ize the result of yasm_version.

Minor build issue fix, regression from 49, please uplift to aurora
Attachment #8761479 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Confirmed fixed, my last aurora build turned green: http://buildbot.rhaalovely.net/builders/mozilla-aurora-amd64/builds/1732
Status: RESOLVED → VERIFIED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.