Timeline /New Tab page content is lost at refresh if the page tab is dragged and opened in a new window when e10s is enabled

RESOLVED WORKSFORME

Status

()

Firefox
Activity Streams: General
P3
normal
RESOLVED WORKSFORME
2 years ago
8 months ago

People

(Reporter: pauloiegasSV, Unassigned)

Tracking

unspecified
x86_64
All
Points:
---

Firefox Tracking Flags

(e10s-)

Details

Attachments

(1 attachment)

Created attachment 8761643 [details]
Content lost at refresh with e10s.mp4

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.0.19-dev

[Affected Platforms]:
- All Windows
- All Mac OS
- All Linux

[Prerequisites]:
- Firefox has e10s enabled. 
- Latest Activity Stream add-on version (1.0.19-dev) was previously installed on a clean profile.

[Steps to reproduce]:
1. Start Firefox browser with the profile where Activity Stream add-on was previously installed.
2. Open a "Timeline" page from browser toolbar or "New Tab" page.
3. Click and hold the opened page tab and drag it on the screen to open it in a new window.
4. Refresh the page on the new window and observe its behavior.

[Expected results]:
The page content is correctly displayed after refresh.

[Actual results]:
The page content disappears after the refresh and it's never displayed back.

[Notes]:
- This issue only reproduces with e10s enabled.
- The content is displayed back only when a new page of its kind is opened.
- The "New Tab" page displays the "Hang on tight! We are analyzing your history to personalize your experience" message for indefinite time.

Comment 2

2 years ago
unreleased feature.
tracking-e10s: --- → -

Updated

9 months ago
Priority: -- → P3
The issue is no longer reproducible on the latest Activity Stream build 1.12.0-dev-1495127438-a9ca91b it seems to have been fixed along the way by other changes.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.