Can't create folder from 3 pane

VERIFIED FIXED in mozilla0.9.9

Status

SeaMonkey
MailNews: Message Display
P1
major
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Eugene Savitsky, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

({regression})

Trunk
mozilla0.9.9
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Searched thrue bugzilla but couldn't find this bug.

1. Open mail.
2. Crate account.
3. In 3 pane window click right button on a folder and press "New Folder...".
4. Enter name and press OK.
5. Dialog dissapears, but no folder was created.

This also happens from File->New->Mew Folder. Same with Subfolders.

A way to create a folder is only from filter menu.

moz 2002022603

PS It's my first time I use mozilla's mail for mailing from my 3 accounts (I
have my main computer killed :( ).

Updated

17 years ago
Severity: normal → major
Keywords: nsbeta1, regression
QA Contact: esther → sheelar

Comment 1

17 years ago
Main menu item and context menu, IMAP or POP -- no folder created.  Using feb26
commercial trunk.
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

17 years ago
urgent

Comment 3

17 years ago
Cerate folder is working from filter ui, so that is a workaround until 3-pane
new folder works.

Comment 4

17 years ago
cc mstoltz, his checkins look suspicious after reading checkin comments. 
We get this js error 

JavaScript error:
chrome://global/content/dialogOverlay.js line 70: opener has no properties

Updated

17 years ago
Blocks: 127932

Comment 5

17 years ago
backing out mstoltz checkins from last night fixes the filter and new 
folder creation problem in my tree. 

Comment 6

17 years ago
I think we back mstoltz out unless we can fix this really quickly. We're in the
very late stages of 0.9.9 and we can't ship with this regression. 
Blocks: 122050

Updated

17 years ago
QA Contact: sheelar → huang

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 7

17 years ago
I'll have a fix by the end of today - If I don't I'll back out.

Comment 8

17 years ago
*** Bug 128095 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

17 years ago
Reassigning to me, I've got a fix.
Assignee: sspitzer → mstoltz
(Assignee)

Comment 10

17 years ago
Created attachment 71720 [details] [diff] [review]
Fix - don't block access to opener from chrome scripts
(Assignee)

Comment 11

17 years ago
Created attachment 71721 [details] [diff] [review]
Complete patch
Attachment #71720 - Attachment is obsolete: true
Comment on attachment 71721 [details] [diff] [review]
Complete patch

sr=jst
Attachment #71721 - Flags: superreview+

Comment 13

17 years ago
Comment on attachment 71721 [details] [diff] [review]
Complete patch

r=pavlov
Attachment #71721 - Flags: review+

Comment 14

17 years ago
Comment on attachment 71721 [details] [diff] [review]
Complete patch

a=leaf on behalf of drivers.
Attachment #71721 - Flags: approval+
(Assignee)

Comment 15

17 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
*** Bug 128238 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 127958 has been marked as a duplicate of this bug. ***
*** Bug 128256 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 128532 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
Verified on Windows 05-12-20-pr1
Linux 05-12-23-pr1
Mac 05-12-17-pr1
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.