Opening an external link in Nightly only works once

RESOLVED DUPLICATE of bug 1279332

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1279332
2 years ago
2 years ago

People

(Reporter: Stephen Moehle, Unassigned)

Tracking

Trunk
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, fennec50+, firefox50 affected)

Details

(Reporter)

Description

2 years ago
Opening a link in an external app only works once after Nightly has been restarted.

Normally, opening a link in an external app will cause the browser to come to the front and open and display the URL. Now, it only happens the first time. Subsequent attempts to open a link in an external app will still bring the browser to the front, but Nightly does nothing. It does not open a new tab or give any indication of doing anything.

To duplicate:
1) Click on a link in an external app. I am using Feedly, an RSS reader.
2) Nightly comes to the front and the link URL is displayed.
3) Go back to the external app and open another link.
4) Nightly comes to the front, but there is no further activity.
5) Kill Nightly by swiping it away in the task list.
6) Go back to the external app and open another link.
7) Nightly comes to the front and displays the link URL.

I first noticed this problem in the 6/8 build. I know that it was working fine one or two days earlier.

Device: Nexus 7 tablet, Android Marshmallow 6.0.1
I noticed this too. At first I thought this was an issue with a third-party app but it looks like this is actually a bug in the browser.
Severity: normal → critical
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
status-firefox49: --- → unaffected
status-firefox50: --- → affected
Ever confirmed: true
Could be related to bug 1279332 too.
Depends on: 1279332
Yep, fixed by backout in bug 1279332.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1279332

Updated

2 years ago
tracking-fennec: ? → 50+
You need to log in before you can comment on or make changes to this bug.