Closed Bug 1279441 Opened 5 years ago Closed 5 years ago

The event details are dismissed if clicking on the detailed code

Categories

(DevTools :: Framework, defect, P1)

50 Branch
defect

Tracking

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected, firefox50 verified)

VERIFIED FIXED
Firefox 50
Iteration:
50.1 - Jun 20
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- verified

People

(Reporter: mboldan, Assigned: jdescottes)

References

Details

(Keywords: regression, Whiteboard: [devtools-html])

Attachments

(1 file)

[Affected versions]:
- Firefox 50.0a1 (2016-06-09)

[Affected platforms]:
- Windows 10 x64, Mac OS X 10.11.1, Ubuntu 14.04 x64

[Steps to reproduce]:
1. Launch Firefox.
2. Open the Inspector and click on an available 'ev' icon.
3. Click on one of the available detailed lines.
4. Click on the displayed code a few times.

[Expected result]:
- The pointer is positioned where the click is performed.

[Actual result]:
- The event details pop-up is dismissed.

[Regression range]:
- This is a regression since the bug is not reproducible on the previous builds.
- I didn't search for the regression range, since a patch is ready to be pushed.
QA Whiteboard: [qe-dthtml]
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Attachment #8762016 - Flags: review?(bgrinstead) → review+
Comment on attachment 8762016 [details]
Bug 1279441 - fix HTMLTooltip closing after click on inner iframe;

https://reviewboard.mozilla.org/r/58934/#review55910
Iteration: --- → 50.1
Flags: qe-verify+
Priority: -- → P1
Whiteboard: [devtools-html] [triage] → [devtools-html]
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/52b012fa432c
fix HTMLTooltip closing after click on inner iframe;r=bgrins
https://hg.mozilla.org/mozilla-central/rev/52b012fa432c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
The issue is no longer reproducible on Firefox 50.0a1 (2016-06-12).
The tests were performed on Windows 10 x64, Mac OS X 10.11.1 and on Ubuntu 16.04 x64.
I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.