Need Custom Installer for OS X

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
17 years ago
14 years ago

People

(Reporter: hangnail, Assigned: dveditz)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8+)
Gecko/20020225
BuildID:    20020225

Most if not all other platforms have an installer that can install only the
desired components.  The disk image distribution is great if you want everything
but if you are only interested in the browser then you get all the other stuff
that is not needed or desired.

Reproducible: Always
Steps to Reproduce:
1.Download osx distro
2.Try to find a way to customize compents
3.Bang head when you can't ;)

Actual Results:  I get everything and don't want everything

Expected Results:  Provide either an installer or net based installer like in
other platforms

Not much more :)

Updated

17 years ago
QA Contact: bugzilla → gbush

Comment 1

17 years ago
Sorry, we have no plans at this time for a modular installer for OS X
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 2

17 years ago
verified
Status: RESOLVED → VERIFIED
*** Bug 135245 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
BTW, while we aren't doing a custom installer there is another bug logged for a
browser only dist for OS X (I forget the #)
*** Bug 161676 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Probably should have been duped to bug 89659.
Summary: Need Custom Installer for OSX → Need Custom Installer for OS X

Comment 7

16 years ago
*** Bug 182233 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
>Sorry, we have no plans at this time for a modular installer for OS X

Well, how about an option in the Preferences to "Deactivate" unwanted
components. I would this this would be useful for all installs.

-Michael

Comment 9

16 years ago
if you have no plans, does that mean you won't consider this feature later? 
would a resolution of "later" be more appropriate?  i'd hate to see this never
get done.

Comment 10

16 years ago
WONTFIX means WILL NOT FIX.  Don't read something else into my "no plans"
comment - I was just being polite.
(Reporter)

Comment 11

16 years ago
Chimera works for OSX users who don't want mail an news.  Don't know if there is
a  phoenix port in the works for those who want themes or are still on classic OS.

Comment 12

16 years ago
i can't stand chimera (lots of dealbreakers for me: no image blocking, no cookie
details), and it seems a reasonable request, seeing as both windows and linux
(and for a time, classic mac os) have net/custom installers.  phoenix for mac is
at best an alpha (it's done by one guy in his spare time, not the phoenix team),
so i guess it's back to full browser for me, i suppose.  maybe i'll try to find
the "port phoenix to mac os x" bug and add some annoying comments there. :)

Comment 13

16 years ago
Not that I care one way or the other (not owning a mac), but would it not be
better to mark this bug HELPWANTED than WONTFIX?

WONTFIX implies that even if someone handed netscape a fully working solution on
a plate, it would not be accepted for some reason (like the infamous 'disable
marquee bug').

HELPWANTED implies that netsape, and any of the core mozilla developers hav no
plans or interest in writing such a thing, but if anyone wants to scartch the
itch there's a chance that it might get checked in.

Is there a particular reason why an installer for OSX that allowed components to
be deactivated would not be accepted?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.