Closed Bug 127948 Opened 18 years ago Closed 14 years ago

microsoft.com - advanced search table missing

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: langer_mann, Unassigned)

References

()

Details

(Keywords: top100, top500)

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

On http://support.microsoft.com/default.aspx? there should be a new search
window with fields to enter search phrases on the top left of the page, the only
thing, that is displayed is the headline ("Search (KB)") ,a button (->) and a
link "Search now"

Reproducible: Always
Steps to Reproduce:
1. Go to www.microsoft.com
2. Click on "Support" (left side, below Ressources)
3.

Actual Results:  the page displayed without the fileds on the top left

Expected Results:  There should be some fields to enter the search phrase
<script FOR="window" EVENT="onLoad()" >setcookieval("Params", "SD=GN");</script>

That's the script that creates that form.  Too bad this FOR="window" business is
an IE-only syntax... No browser I have here (Mozilla, Netscape4, Amaya) shows
that form.
Assignee: alexsavulov → doronr
Status: UNCONFIRMED → NEW
Component: Form Submission → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: vladimire → zach
Version: other → unspecified
Keywords: evang500
Oddly enough, the search form fields do display in NS 6.2.1
Today, going to support.microsoft.com with Mozilla 0.9.9, nothing is displayed
at all.  I get a completely blank display.  If I pull up page source, all I see
is one line:

<!--TOOLBAR_EXEMPT-->

and that is it.  If I go there with IE, I see the proper page.  (Of course.) 
With Communicator 4.7, the page also loads properly -- if rather slower than IE.
*** Bug 141749 has been marked as a duplicate of this bug. ***
taking
Assignee: doron → bclary
Blocks: MS
Summary: microsoft search form doesn't get displayed at all → microsoft .com - search form doesn't get displayed at all
Summary: microsoft .com - search form doesn't get displayed at all → microsoft.com - search form doesn't get displayed at all
mhmm... tried that page today and it seems to work at least a little... now you
can enter some searchphrase and it even searches... i've upgraded to Mozilla 1.0
RC2 Build 2002051006. There is just the selection box missing, where you can
select the search topic.
*** Bug 151763 has been marked as a duplicate of this bug. ***
In Mozilla 1.0 Stable release, the only thing missing as Stephan reported is the
Microsoft Topic's column which lists the available Microsoft products you can do
a search on.
It seems this bug, or the MS support page, has changed a few times.  Here's what
I observe now.

The left panel of the Microsoft support page, support.microsoft.com, should include:
a drop-down list of MS products
a field for search text
a show options link that allows further refinement
a search now button/link

In Mozilla 1.0 the drop-down list and show options link are missing, which makes
the search engine useless since the default search (any keyword found, search
all Microsoft products) produces too many results.  I first noticed this problem
in Netscape 4 after Microsoft revamped the support site in November or December
2001.

I've observed this problem, with the same symptoms, in Mozilla 1.0, Netscape
4.7, and Netscape 4.79, but *not* in Netscape 6.1 or 6.21.  Does anyone with a
Netscape 7 release want to try it?
pure server side sniff. if you change your ua string to IE you will get the full
options in the search however their toolbar will be broken... haven't checked
why... prolly nonstandard css foo.

Looking at their content served to IE they are providing DOM compliant code
paths so they are beginning to change. Perhaps they are performing an
incremental roll out of the new functionality. 

Lets follow up again in August to see how they are doing.
Target Milestone: --- → Aug
Within the last week, Microsoft changed the appearance of support.microsoft.com.
 It now has a single field for search text.  In IE 5.5 and Netscape 6.21,
there's an Advanced link below that.  In any browser there's a Search the
Knowledgebase link to the right with URL identical to the Advanced link.  In IE
and Netscape 6, this produces the advanced search page.  In Mozilla, it produces
a page with the search table missing and poorly formatted text.

Test: I opened the advanced support page in Internet Explorer, then saved as
complete web page.  I opened the saved page in Mozilla 1.0 - the table works
properly and the text is well formatted.  (Note: the saved page doesn't work in
Netscape 4.79.)

Rant: Although Microsoft didn't reply to my complaints (in December), I assume
the justification is that they use the best available web design tools and can't
be responsible for troubles with inferior browsers.  (Not my opinion, I'm
attempting to channel Microsoft.)  Since my test shows that Mozilla is perfectly
capable of displaying the page, I can only assume that the web site deliberately
failed to provide a full version of that page.  Surely there are 9 state
Attorneys General who would be interested in this.
is bug 159494 a dup?
*** Bug 161674 has been marked as a duplicate of this bug. ***
Bug 159494 is certainly related, in that it is server-side sniffing evang bug 
on support.microsoft.com.  However, that bug deals with unreadable pages due to 
the (valid) CSS that is being served, whereas this bug deals with the decision 
not to serve up part of the document.  I don't think it's a dup, unless we want 
to turn this into a 'support.microsoft.com doesn't like Mozilla' bug.
I see the search field when my ua string is:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1) Gecko/20020710
Netscape/7.0 

or

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2) Gecko/20020510
re: #15

It's not the search field that's missing, it's the advanced search table.  Read
my comment #11 for complete, if poorly worded, detail.

It's still missing in Moz 1.1.  If the ua string is what shows up in the top
part of Help..About Mozilla, then mine is
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

No problem in Netscape 6.21
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20011128
Netscape6/6.2.1
With a Mozilla user agent string, I see the search field, Serach the
KNowledgebase, and a --> button. I *do not* see an Advanced Search link.
I changed the subject line to reflect this.

Overall the issue is that they are only detecting Netscape, not Gecko.
I am contacting them about other support.microsoft.com issues (link below) so
will take this bug also.
http://bugzilla.mozilla.org/show_bug.cgi?id=159494
Assignee: bclary → susiew
Summary: microsoft.com - search form doesn't get displayed at all → Support.microsoft.com - Advanced Search link missing
Summary: Support.microsoft.com - Advanced Search link missing → microsoft.com - Advanced Search link missing
The URL for this page has changed slightly,
http://support.microsoft.com/default.aspx?scid=fh;en-gb;kbhowto

In order to see the Advanced Search dialogue you must spoof as NS6:

user_pref("general.useragent.vendor", "Netscape6");
user_pref("general.useragent.vendorSub", "6.5");

Now, if you go to the URL in this comment you see the dialogue, but it is cut
off at the right hand side. Clicking Reload doesn't fix it however, if you go
to another page (your home page will do) then clicking back causes it to be
rendered properly.

Whilst MS's CSS may be contributing to this I suspect that Moz is partly (or
wholly?) to blame because it renders fine on the second visit.

See screenshots.
*** Bug 190084 has been marked as a duplicate of this bug. ***
Can the summary for this bug be changed?  "...Advanced search link missing" was
never the heart of this problem, and has become inaccurate since Microsoft
restored the link a few months ago.  Something that reflects the unusable state
of the advanced search page - "support.microsoft.com advanced search table missing".
done
Summary: microsoft.com - Advanced Search link missing → microsoft.com - advanced search table missing
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
Target Milestone: Aug → ---
*** Bug 247975 has been marked as a duplicate of this bug. ***
(In reply to comment #21)
> Can the summary for this bug be changed?  "...Advanced search link missing" was
> never the heart of this problem, and has become inaccurate since Microsoft
> restored the link a few months ago.  Something that reflects the unusable state
> of the advanced search page - "support.microsoft.com advanced search table
missing".

The link is missing when I go there, so I think that it is still accurate
The latest version of the Microsoft knowledgebase advanced search page, changed
within the last week, works in Mozilla 1.7.1 and Firefox 0.9.2 (Windows XP sp1).

The search page and its level of compatibility with Mozilla is subject to change
by Microsoft - as the history of this bug, and the repeated obsolesence of its
summary, shows.
Keywords: top500
Keywords: top100
Is this bug still valid? The URL above (http://support.microsoft.com/default.aspx?) looks the same for me in both IE6 SP1 (Windows 2000) and Seamonkey SeaMonkey 1.0.4 (Gecko 1.8.0.6 20060729) albeit with added whitespace off the bottom of the page.

However all page elements, search fields, columns of text appear identical.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.