Search suggestions are no longer displayed after performing a search and returning to New Tab page

RESOLVED WONTFIX

Status

()

Firefox
Activity Streams: General
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: cmuresan, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

Created attachment 8762019 [details]
going back to the new tab page after confirming a search with Enter key.mp4

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.0.19-dev

[Affected Platforms]:
- All Windows
- All Mac OS X
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on version (1.0.19-dev) was previously installed on a clean profile.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites. 
2. Open a New Tab and write something in the "Search" bar.
3. Press the "Enter" key.
4. Click on "Back" button to return to New Tab page.
5. Write a keyword in the search textbox and observe the behavior.

[Expected result]:
The search suggestion dropdown is updated with the new string.

[Actual result]:
The search suggestion dropdown is not displayed and will not be displayed when adding keywords.

[Notes]:
- If you click outside the search bar and then back to it, the search suggestion dropdown appears.
- Attached a screen recording of the issue.
Component: Activity Streams: Newtab → Activity Streams: General
Closing as wont fix since the back button is no longer available in the system-addon version of Activity Stream.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.