problems when opening new tab immediately after entering input in location bar on browser startup (FF 40+)

RESOLVED DUPLICATE of bug 1000458

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1000458
a year ago
a year ago

People

(Reporter: Hattie, Unassigned)

Tracking

47 Branch
Unspecified
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
PREREQ:
for the purposes of reproducing, i recommend setting "When Firefox starts" to "Show a blank page", so that the location bar is focused when you start Firefox -- this will help you to more quickly follow reproduction steps, as timing is important.

STEPS TO REPRODUCE:
if, on browser startup, the user immediately and quickly types (or pastes (which i recommend for easier reproduction)) a domain (tested with e.g. red.com and google.com) or search phrase (tested with e.g. "red" and "google") into the location bar and then immediately presses enter, and then immediately presses Ctrl-t to open a new tab ...

RESULT:
the result will be that the domain or search entered in the original tab does not get loaded, and (sometimes) the text from the location bar in the first tab gets copied to the location bar in the second tab (when the text does get copied to the second tab location bar, the second tab's location bar also doesn't get focused as it normally does when opening a new tab).

I noticed one instance where the text copied to the second tab's location bar had been changed from "red.com" to "http://red.com/" (when i checked the first tab, i could see it was changed there as well) -- just another clue that might help to determine at what stage this bug occurs.

note that if you paste the domain or search and press enter before the pasted text actually shows in the location bar, you're more likely to see the results noted above when following the steps above, but this issue occurs even if you wait for the pasted text to show before pressing enter (though it's harder to reproduce if you wait since timing is important).

i've noticed this issue for the past few releases, at least.

this is incredibly frustrating for me, because when i open the browser, i very often want to quickly check two or more sites. i run into this bug at least a couple times a week.

tested on Windows 10 and Linux.
(Reporter)

Comment 1

a year ago
another clue -- I just noticed this can happen at times other than immediately after startup (though far less frequently, as I've only seen so once). I opened firefox, navigated to gmail.com, logged-in, checked to see if there were any messages, and logged-out. once the logged-out screen was showing (but before the spinning loading indicator disappeared), i pressed Ctrl-L to focus the location bar, typed a search, pressed enter, and then pressed Ctrl-T to open a tab. the symptoms noted above presented themselves. this was about 1 minute after opening firefox.

i recommend following the reproduction steps from the original post -- this is just FYI that it can happen as much as a minute after startup.
I can't reproduce on OS X with Firefox 47 or Nightly.  Would you mind seeing if you can reproduce in a new Firefox profile?
(Reporter)

Comment 3

a year ago
I am able to reproduce in a new profile (with only change being that listed under "PREREQ" above), although it's harder to do -- it seems this bug is dependent upon performance factors (and a new profile, not having any extensions installed, seems less inclined to allow reproduction). I was able to reproduce in a new profile within a virtual machine. I tested FF 47 on Windows 7 within VirtualBox and was able to reproduce about half the time (I could go several times in a row being able to reproduce or not; it seems to depend a lot on how fast I am able to follow the reproduction steps in a given moment).

I was not able to reproduce in a new profile outside of a virtual environment (probably because the resources are less constrained outside a VM). However, I noticed that installing a few big extensions allowed me to sometimes reproduce within an otherwise new profile. The number and complexity of extensions installed (as opposed to which particular extensions) seems to be a factor in my testing.

I did some testing on older versions (in a VM) and found that this issue goes back to at least Firefox 40 (I have not been able to reproduce in FF 39). I noticed that, after installing a different Firefox version, I was not able to reproduce the first few times I opened Firefox (maybe Firefox is doing some upgrade maintenance the first few running minutes or the first few runs which somehow prevents this) ... I noticed that in these first few runs, the new tab seemed to be slower to open -- perhaps this slowness happens to stave off a race condition? Anyway, after the first few runs following a change of Firefox version, I am again able to reproduce about half the time.
Summary: problems when opening new tab immediately after entering input in location bar on browser startup → problems when opening new tab immediately after entering input in location bar on browser startup (FF 40+)
I think this is a dupe of bug 1000458.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1000458
You need to log in before you can comment on or make changes to this bug.