Unable to collapse side bar items in todays build

VERIFIED FIXED

Status

SeaMonkey
Sidebar
P3
normal
VERIFIED FIXED
19 years ago
10 months ago

People

(Reporter: Scott MacGregor, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In a fresh pull of the tree today, I am unable to collapse items in my sidebar.
In my example, my mailnews sidebar has a stock ticker and the fish cam in it. If
I attempt to collapse one of them, the entire sidebar goes blank.

If I close and re-open the sidebar, I assert here:
"bad col frame"

FixedTableLayoutStrategy::AssignPreliminaryColumnWidths(int 2220) line 90 + 32
bytes
BasicTableLayoutStrategy::Initialize(nsSize * 0x00000000 {width=??? height=???},
int 1, int 2220) line 79
nsTableFrame::BalanceColumnWidths(nsIPresContext & {...}, const
nsHTMLReflowState & {...}, const nsSize & {width=2220 height=1073741824}, nsSize
* 0x00000000 {width=??? height=???}) line 3689
nsTableFrame::Reflow(nsTableFrame * const 0x043ee344, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 2163
nsTreeFrame::Reflow(nsTreeFrame * const 0x043ee344, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 320 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x043ee340, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 439 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x043eaa64, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 927 + 37 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x043eaa60, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {"initial"}) line 948
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=0 y=0 width=2220
height=1875}) line 577
nsBoxFrame::Reflow(nsBoxFrame * const 0x03e4ed6c, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 412
nsContainerFrame::ReflowChild(nsIFrame * 0x03e4ed68, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 439 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x043e9c64, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 327
nsContainerFrame::ReflowChild(nsIFrame * 0x043e9c60, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 439 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x043e5574, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 513
PresShell::ResizeReflow(PresShell * const 0x04250580, int 2220, int 1875) line
881
PresShell::ResizeReflow(PresShell * const 0x04250584, nsIView * 0x04250980, int
2220, int 1875) line 1946
nsViewManager::SetWindowDimensions(nsViewManager * const 0x04250e80, int 2220,
int 1875) line 355
nsViewManager::DispatchEvent(nsViewManager * const 0x04250e80, nsGUIEvent *
0x0012bdc4, nsEventStatus & nsEventStatus_eIgnore) line 1436

Updated

19 years ago
Summary: Unable to collapse side bar items in todays build

Updated

19 years ago
OS: Windows NT → All

Comment 1

19 years ago
*** Bug 12903 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

18 years ago
This should be ok now.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
this is ok, there is a separate bug for bookmarks not collapsing
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.