Closed Bug 1279526 Opened 4 years ago Closed 3 years ago

Firebug theme: fix CSS for rule view property

Categories

(DevTools :: Inspector: Rules, defect, P1)

defect

Tracking

(firefox50 fixed)

RESOLVED FIXED
Firefox 50
Tracking Status
firefox50 --- fixed

People

(Reporter: Honza, Assigned: gasolin, NeedInfo)

Details

(Whiteboard: [good taipei bug])

Attachments

(1 file)

This is a follow up for bug 1274760

From:
https://bugzilla.mozilla.org/show_bug.cgi?id=1274760#c7

--

One more thing!
The rule that follows at the end of the change:

 .theme-firebug .ruleview-enableproperty:not([checked]) ~ .ruleview-computedlist * {
   color: #CCCCCC;
 }

seems wrong.  The reason for that is that .ruleview-enableproperty and .ruleview-computedlist are not siblings since Firefox 40 (they were siblings in Firefox 39). The rule is intended to make gray the listed (sub) properties from a shorthand property when that shorthand property is disabled.  Given these are not siblings any longer it is hard to fix this with just css.  The best I am able to do is to replace the rule with:

.theme-firebug .ruleview-overridden > * > .ruleview-computed:not(.ruleview-overridden),
.theme-firebug .ruleview-overridden > * > .ruleview-computed:not(.ruleview-overridden) > .ruleview-propertyname,
.theme-firebug .ruleview-overridden > * > .ruleview-computed:not(.ruleview-overridden) > .ruleview-propertyvalue {
  color: #CCCCCC;
}

This works for me but has a problem when disabling a property overridden in another rule.  In such case, it will not apply until inspecting another node.

Also see a screenshot:
https://bugzilla.mozilla.org/attachment.cgi?id=8761782&action=edit

Honza
Inspector bug triage (filter on CLIMBING SHOES).
Tagging as P1 like bug 1274760.
Priority: -- → P1
Honza: do you think P1 is the right priority for this bug. No one has taken a look at this bug in the last month. Should someone urgently investigate the issue here?
Flags: needinfo?(odvarko)
(In reply to Patrick Brosset <:pbro> from comment #2)
> Honza: do you think P1 is the right priority for this bug. No one has taken
> a look at this bug in the last month. Should someone urgently investigate
> the issue here?

Yes, I am planning to have this done by someone from the Taipei office.

Honza
Flags: needinfo?(odvarko)
Whiteboard: [good taipei bug]
The patch is took from johngraciliano 's comment from bug 1274760 comment 10

All padding color will turn to grey when the block sign is tapped.
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Does the patch look correct to you?

Honza
Flags: needinfo?(johngraciliano)
Attachment #8770362 - Flags: review?(odvarko) → review+
Comment on attachment 8770362 [details]
Bug 1279526 - Firebug theme: fix CSS for rule view property;

https://reviewboard.mozilla.org/r/63828/#review61862

I tested this and works for me, thanks!

Honza
thanks!
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/c96249f34046
Firebug theme: fix CSS for rule view property; r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c96249f34046
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
I have reproduced this bug with Nightly 50.0a1 (2016-06-10) on Windows 7, 64 Bit !

This bug's fix is verified with latest developer edition (Aurora)

Build ID   20160907004009
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
[bugday-20160907]
I have reproduced this bug with Nightly 50.0a1 (2016-06-10) on Windows 7, 64 Bit !

This bug's fix is verified with latest developer edition (Aurora)

Build ID   20160907004009
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
[bugday-20160907]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.