Events details popup is sometimes empty, e.g. on google.de

RESOLVED DUPLICATE of bug 1042965

Status

()

Firefox
Developer Tools: Framework
RESOLVED DUPLICATE of bug 1042965
2 years ago
2 years ago

People

(Reporter: Jens, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8762260 [details]
Empty events popup

On https://www.google.de/ (probably also at other pages) there are some "ev" that result in an *empty* popup when clicked. See screenshot. I guess this is caused by refactorings in Bug 1266450

BTW: It would be nice if the popup would not restrict the user with what she can copy'n'paste: E.g. the clickable headings of the popup like "Resize httsp://google.de:68" cannot be selected and copied. I found this at various parts of the Devtools that text you would sometimes copy to pass around, and the Devtools won't let me do. Would this issue be worth another report? I would appreciate if something like this would be considered upfront when reimplementing the popups anyway.
FWIW I don't see the event details icon show up at all on the #csi textarea on google.de.  Do you always see the icon or is it intermittently showing up?
Flags: needinfo?(nachtigall)
(In reply to Jens from comment #0)
> BTW: It would be nice if the popup would not restrict the user with what she
> can copy'n'paste: E.g. the clickable headings of the popup like "Resize
> httsp://google.de:68" cannot be selected and copied. I found this at various
> parts of the Devtools that text you would sometimes copy to pass around, and
> the Devtools won't let me do. Would this issue be worth another report? I
> would appreciate if something like this would be considered upfront when
> reimplementing the popups anyway.

We usually don't allow text selection on pieces of the devtools chrome, so I don't know if we'd want to support it for the sake of consistency.
It looks like you need to have the "itsalltext" [1] extension to reproduce the issue here.

The events on the csi element are added by the addon.
If you use a non-e10s window, the event details popup will contain the events.
If you use an e10s window, the event details popup will be empty.

I can reproduce this on Firefox dev edition, so this is not linked to Bug 1266450.

[1] https://addons.mozilla.org/en-gb/firefox/addon/its-all-text/
tracking-e10s: --- → ?
See Also: bug 1266450
(Reporter)

Comment 4

2 years ago
Julian is totally right. I just tested with FDE with itsalltext on/off and e10s on/off. It is exactly as he wrote. Thanks for looking into it.

> We usually don't allow text selection on pieces of the devtools chrome, so I don't know 
> if we'd want to support it for the sake of consistency.

Surely another issue and I think I've derailed the issue already enough. But unfortunately, this also means that even error messages sometimes cannot be copied like in this screenhot https://bug1274957.bmoattachments.org/attachment.cgi?id=8755394 (from Bug 1274957).
Flags: needinfo?(nachtigall)

Updated

2 years ago
Blocks: 905436
tracking-e10s: ? → +
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042965
You need to log in before you can comment on or make changes to this bug.