Polish sidebar tab navigation which is ``clunky'' in its current state

NEW
Unassigned

Status

SeaMonkey
Sidebar
16 years ago
6 years ago

People

(Reporter: Samir Gehani, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 rtm],custrtm-)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The tab overlow implementation allows users to move up or down only one tab at a
time when the number of ``included'' tabs in a profile exceeds the
sidebar.num_tabs_in_view pref for the same profile.  We need a way for users to
get to the tab of their choice with less clicks and more ``smmothness'' or
continuity.  This is a usability defect.  

The prescribed solution per UI design, engineering etc. is to navigate normally
till the selected tab hits a boundary, then close the selected tab and bring in
as many as will fit.  We should also disable the navigation buttons (icon change
should suffice) when a bound is hit and there are no more tabs above when we
were moving up or no more tabs below when were moving down.
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
Priority: -- → P3
Summary: Polishd sidebar tab navigation which is ``clunky'' in its current state → Polish sidebar tab navigation which is ``clunky'' in its current state
Target Milestone: --- → mozilla1.0
(Reporter)

Updated

16 years ago
Depends on: 127974

Comment 1

16 years ago
This is a dup of bug 126559
(Reporter)

Comment 2

16 years ago
Nope, not a dupe; this is a short-term usability improvement for the current
implementation.

Comment 3

16 years ago
nsbeta1+ per Nav triage team
Keywords: nsbeta1 → nsbeta1+
(Reporter)

Updated

16 years ago
Blocks: 128352
(Reporter)

Updated

16 years ago
Blocks: 128354
(Reporter)

Updated

16 years ago
Blocks: 128692
(Reporter)

Comment 4

16 years ago
*** Bug 129904 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Blocks: 129905

Updated

16 years ago
Severity: normal → enhancement

Updated

16 years ago
Severity: enhancement → normal
Whiteboard: [adt2]

Comment 5

16 years ago
we need to also fix the following case:

after deleting tab from customize sidebar, we are not showing an open
tab in the sidebar. So for example, if you have Search tab open in
sidebar and you have bookmark tab below it(closed). Then yo go into
Customize Sidebar and delete Search, then click OK on Customize
Sidebar. Then Bookmark tab in sidebar should be the active tab in the
open state.
(Reporter)

Updated

16 years ago
No longer blocks: 128354
(Reporter)

Updated

16 years ago
No longer blocks: 131044
(Reporter)

Comment 6

16 years ago
Yes, thanks for noting this.  I believe this is the dependent bug 128692.
Blocks: 128354, 131044
(Reporter)

Updated

16 years ago
No longer blocks: 128354
(Reporter)

Updated

16 years ago
No longer blocks: 131044

Comment 7

16 years ago
Created attachment 76305 [details]
mac classic sidebar arrows

here is a screen shot of the mac classic sidebar "overflow" arrows. They appear
white and not the grey chrome color that the rest of the sidebar has.

Updated

16 years ago
Blocks: 48251

Updated

16 years ago
Whiteboard: [adt2] → [adt2 rtm]

Updated

16 years ago
Whiteboard: [adt2 rtm] → [adt2 rtm],custrtm-
(Reporter)

Comment 8

16 years ago
-> caillon
Assignee: sgehani → caillon
(Reporter)

Comment 9

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1+ → nsbeta1-
->Back to you samir.
Assignee: caillon → sgehani

Comment 11

15 years ago
Probably easiest solved by doing bug 139855: replace the tabs by a single
dropdown box.

Comment 12

15 years ago
retargeting
Target Milestone: mozilla1.0 → Future
Product: Browser → Seamonkey
Assignee: samir_bugzilla → nobody
Priority: P3 → --
QA Contact: sujay → sidebar
Target Milestone: Future → ---

Comment 13

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 14

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 15

6 years ago
Still valid.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: EXPIRED → ---

Updated

6 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.