Chatzilla Startup preferences not working in Seamonkey

RESOLVED FIXED in seamonkey2.45

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

SeaMonkey 2.45 Branch
seamonkey2.45
All
Unspecified
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.43 unaffected, seamonkey2.44 unaffected, seamonkey2.45 fixed, seamonkey2.46 fixed, seamonkey2.47 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

3 years ago
Starting with Seamonkey 2.45 the following error can be seen in the web console during Chatzilla startup:

>> Timestamp: 6/8/2016 1:52:54 PM
>> Error: TypeError: invalid 'in' operand window.arguments[0]
>> Source File: chrome://chatzilla/content/static.js
>> Line: 795

The startup settings are subsequently ignored.

Starting Chatzilla in a tab or with an url via a link eg. the one on http://www.seamonkey-project.org/community works.

The problem is that bug 1255354 added an additional args parameter for the dialog in the function toOpenWindowByType in suite/common/tasksOverlay.js. The parameter is uninitialized.
Assignee

Comment 1

3 years ago
Needs to be pushed to c-c, c-a and c-b if ok. I thought about putting the dialog feature parms in a variable but with just one duplicate line and also nearby in case someone changes this I thought it's not worth it.

[Approval Request Comment]
Regression caused by (bug #): 1255354
User impact if declined: Chatzilla startup preferences not working.
Testing completed (on m-c, etc.): c-b to c-c
Risk to taking this patch (and alternatives if risky): none already broken.
String changes made by this patch: none

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

Needs to be pushed to c-c, c-a and c-b if ok.
Attachment #8762371 - Flags: review?(philip.chee)
Attachment #8762371 - Flags: approval-comm-beta?
Attachment #8762371 - Flags: approval-comm-aurora?

Updated

3 years ago
Attachment #8762371 - Flags: review?(philip.chee)
Attachment #8762371 - Flags: review+
Attachment #8762371 - Flags: approval-comm-beta?
Attachment #8762371 - Flags: approval-comm-beta+
Attachment #8762371 - Flags: approval-comm-aurora?
Attachment #8762371 - Flags: approval-comm-aurora+

Comment 2

3 years ago
Comment on attachment 8762371 [details] [diff] [review]
1279738-chatzilla-startup.patch

r=me a=me

> +    if (args) {
> +      window[uri] = openDialog(uri, "",
> +                               features || "non-private,all,dialog=no",
> +                               args || null);
If (args) is truth-like then it can't be null, no?
Assignee

Comment 3

3 years ago
Patch with small change to argument checking as discussed on IRC. Review+ and Approval for c-b and c-a from Philip Chee carried forward.
Attachment #8762371 - Attachment is obsolete: true
Attachment #8763214 - Flags: review+
You need to log in before you can comment on or make changes to this bug.