"Highlight All" dim is scaled when page has horizontal scroll bar.

VERIFIED FIXED in Firefox 52

Status

()

Toolkit
Find Toolbar
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: arai, Assigned: mikedeboer)

Tracking

({nightly-community, regression, testcase})

50 Branch
mozilla52
nightly-community, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox49 unaffected, firefox50+ disabled, firefox51 disabled, firefox52 verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8762325 [details]
Test page with width: 2000px

When a page is wider than the window and has horizontal scrolllbar,
dim of Highlight All is scaled

Steps to reproduce:
  1. make the width of browser window less than 2000px
  2. load attached HTML
  3. search "TEST"
  4. Click "Highlight All"

Actual result:
  Dim is scaled and doesn't match to actual words in the page

Expected result:
  Dim is not scaled and cover entire page
(Reporter)

Comment 1

2 years ago
Created attachment 8762326 [details]
screenshot of scaled dim

Updated

2 years ago
Keywords: nightly-community, testcase
(Assignee)

Updated

2 years ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Created attachment 8762508 [details] [diff] [review]
Patch v1: render the highlighter mask using plain HTML and CSS

I will start using MozReview soon, I promise. :/
Attachment #8762508 - Flags: review?(jaws)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1279721
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1279719
(Assignee)

Comment 5

2 years ago
Comment on attachment 8762508 [details] [diff] [review]
Patch v1: render the highlighter mask using plain HTML and CSS

I need to take care of a few more details here.
Attachment #8762508 - Flags: review?(jaws)
(Assignee)

Comment 6

2 years ago
Created attachment 8762665 [details] [diff] [review]
Patch v2: render the highlighter mask using plain HTML and CSS
Attachment #8762508 - Attachment is obsolete: true
Attachment #8762665 - Flags: review?(jaws)
(Assignee)

Updated

2 years ago
Blocks: 1279717
[Tracking Requested - why for this release]: Regression
status-firefox49: --- → unaffected
status-firefox50: --- → affected
tracking-firefox50: --- → ?
Keywords: regression
Version: unspecified → 50 Branch
(Assignee)

Updated

2 years ago
Blocks: 1279715
Comment on attachment 8762665 [details] [diff] [review]
Patch v2: render the highlighter mask using plain HTML and CSS

Review of attachment 8762665 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/modules/FinderHighlighter.jsm
@@ +77,2 @@
>  }`;
>  const kSVGNS = "http://www.w3.org/2000/svg";

Looks like kSVGNS can be removed, also in _modalHighlight there is another reference to SVG that is no longer correct with this patch.
Attachment #8762665 - Flags: review?(jaws) → review+
(Assignee)

Comment 10

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/ccae8d5e75869480d64882bc6f797e3433a8d00c
Bug 1279742 - render the highlighter mask using plain HTML and CSS, instead of an SVG document. This improves performance and solves various layouting issues. r=jaws
(Assignee)

Updated

2 years ago
Blocks: 1279752
(Assignee)

Updated

2 years ago
Blocks: 1279710
(Assignee)

Updated

2 years ago
Blocks: 1279682
(Assignee)

Updated

2 years ago
Blocks: 1280149
No longer blocks: 1279752
Duplicate of this bug: 1279752

Comment 12

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ccae8d5e7586
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Tracking 50+ for this scaling regression.
tracking-firefox50: ? → +
Flags: qe-verify+
status-firefox50: fixed → disabled
status-firefox51: --- → disabled
status-firefox52: --- → fixed
Target Milestone: mozilla50 → mozilla52
Reproduced the initial issue using Nightly 50.0a1 (Build ID: 20160611030214) on Windows 10. 

Verified fixed using the latest Nightly 52.0a1 (Build ID: 20160928030201) on Windows 10 x64bit, Ubuntu 16.04 and Mac OS X 10.11.
Status: RESOLVED → VERIFIED
status-firefox52: fixed → verified
You need to log in before you can comment on or make changes to this bug.